Adminer has an Unauthenticated Persistent DoS via Array Injection in ?script=version Endpoint
CVE-2026-25892GHSA-q4f2-39gr-45jh
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (vrana/adminer 5.4.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist vrana/adminer
- Affected
- >= 4.6.2, < 5.4.2
- Fixed in
- 5.4.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-q4f2-39gr-45jh lists affected ranges: Packagist vrana/adminer >=4.6.2 <5.4.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2026-25892: 1.72% estimated exploitation activity in the next 30 days; percentile 77.47 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Adminer v5.4.1 has a version check mechanism where adminer.org sends signed version info via JavaScript postMessage, which the browser then POSTs to ?script=version. This endpoint lacks origin validation and accepts POST data from any source. An attacker can POST version[] parameter which PHP converts to an array. On next page load, opensslverify() receives this array instead of string and throws TypeError, returning HTTP 500 to all users. Fix Upgrade to Adminer 5.4.2. Mitigation (if you can't upgrade): Make file adminer.version in temp directory (usually the value of uploadtmpdir) unwritable by web server. Details 1. Intended design of ?script=version: The endpoint is designed to receive version data from adminer.org via browser JavaScript: - functions.js line 102-117: Creates iframe to https://www.adminer.org/version/ - Adminer.org sends signed version data via postMessage - JavaScript POSTs this to ?script=version - Server stores in /tmp/adminer.version for signature…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-q4f2-39gr-45jh
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-25892 Advisory: Adminer has an Unauthenticated Persistent DoS via Array Injection in ?script=version Endpoint IDs: CVE-2026-25892, GHSA-q4f2-39gr-45jh Record: https://patchnext.com/advisories/cve-2026-25892 (revision 1, source checked 26 Oct 2026, 14:38 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: vrana/adminer 5.4.2. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist vrana/adminer: affected >= 4.6.2, < 5.4.2; fixed in 5.4.2 ## Suggested inspection (read-only) - Packagist vrana/adminer: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on vrana/adminer. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-q4f2-39gr-45jh (GitHub-reviewed advisory GHSA-q4f2-39gr-45jh lists affected ranges: Packagist vrana/adminer >=4.6.2 <5.4.2) Commands are suggestions: review each one before running it.
Loading voting…