Langroid has Prompt to SQL Injection, Leading to RCE
CVE-2026-25879GHSA-mxfr-6hcw-j9rq
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (langroid 0.63.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI langroid
- Affected
- < 0.63.0
- Fixed in
- 0.63.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-mxfr-6hcw-j9rq lists affected ranges: PyPI langroid >=0 <0.63.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-mxfr-6hcw-j9rq lists affected ranges: PyPI langroid >=0 <0.63.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2026-25879: 0.55% estimated exploitation activity in the next 30 days; percentile 46.32 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Security Vulnerability Report: Prompt to SQL Injection leading to RCE in latest Langroid Affected Scope langroid < 0.63.0 Vulnerability Description SQLChatAgent executes SQL produced by an LLM, which is influenceable by prompt injection. When configured with a database role that has privileges enabling code execution or filesystem access (e.g., PostgreSQL pgexecuteserverprogram, MySQL FILE, MSSQL xpcmdshell), an attacker who can shape the agent's input — including indirectly via data returned to the LLM — can coerce execution of dialect-specific primitives such as COPY ... FROM PROGRAM, achieving RCE on the database host. Fixed in vX.Y by defaulting SQLChatAgent to a SELECT-only sqlglot-parsed statement allowlist with a dialect-aware dangerous-pattern blocklist; allowdangerousoperations=True restores the previous unrestricted behavior for trusted deployments. Reproduction & PoC This demo can be used to reproduce the vulnerability: The POC demonstrates successful command execution…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-mxfr-6hcw-j9rq
- Revision 2 · amended ·
Amended from osv record GHSA-mxfr-6hcw-j9rq
- Revision 1 · created ·
Published from ghsa record GHSA-mxfr-6hcw-j9rq
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-25879 Advisory: Langroid has Prompt to SQL Injection, Leading to RCE IDs: CVE-2026-25879, GHSA-mxfr-6hcw-j9rq Record: https://patchnext.com/advisories/cve-2026-25879 (revision 3, source checked 26 Oct 2026, 13:46 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: langroid 0.63.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI langroid: affected < 0.63.0; fixed in 0.63.0 ## Suggested inspection (read-only) - `python -m pip show langroid`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on langroid. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-mxfr-6hcw-j9rq (GitHub-reviewed advisory GHSA-mxfr-6hcw-j9rq lists affected ranges: PyPI langroid >=0 <0.63.0) - Verified: https://osv.dev/vulnerability/GHSA-mxfr-6hcw-j9rq (OSV record GHSA-mxfr-6hcw-j9rq lists affected ranges: PyPI langroid >=0 <0.63.0 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…