Antrea has invalid enforcement order for network policy rules caused by integer overflow
CVE-2026-25804GHSA-86x4-wp9f-wrr9
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (antrea.io/antrea 2.4.3, 2.3.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 2.3.2>= 2.4.0, < 2.4.3
- Fixed in
- 2.4.3, 2.3.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-86x4-wp9f-wrr9 lists affected ranges: Go antrea.io/antrea >=0 =2.4.0 <2.4.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.0 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:L/SC:N/SI:N/SA:N/E:U · score source
- EPSS
- CVE-2026-25804: 0.49% estimated exploitation activity in the next 30 days; percentile 42.33 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Antrea's network policy priority assignment system has a uint16 arithmetic overflow bug that causes incorrect OpenFlow priority calculations when handling a large numbers of policies with various priority values. This results in potentially incorrect traffic enforcement. If a user creates a large number of Antrea NetworkPolicies (ANP or ACNP) with varying priorities, some rules with lower logical priorities (higher numerical priority values) may take precedence over rules with higher logical priorities (lower numerical priority values). Traffic that should be denied by the configured Antrea NetworkPolicies may end up being allowed, potentially letting an attacker access a sensitive service. Traffic that should be allowed by the configured Antrea NetworkPolicies may end up being denied, breaking applications and potentially opening the door for denial-of-service attacks. The Antrea NetworkPolicy system comes with support for priority Tiers. Rules defined within a Tier cannot…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-86x4-wp9f-wrr9
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-25804 Advisory: Antrea has invalid enforcement order for network policy rules caused by integer overflow IDs: CVE-2026-25804, GHSA-86x4-wp9f-wrr9 Record: https://patchnext.com/advisories/cve-2026-25804 (revision 1, source checked 26 Oct 2026, 15:14 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.0) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: antrea.io/antrea 2.4.3, 2.3.2. A vendor fix does not mean a deployment is fixed. ## Affected components - Go antrea.io/antrea: affected < 2.3.2; >= 2.4.0, < 2.4.3; fixed in 2.4.3, 2.3.2 ## Suggested inspection (read-only) - Go antrea.io/antrea: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on antrea.io/antrea. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-86x4-wp9f-wrr9 (GitHub-reviewed advisory GHSA-86x4-wp9f-wrr9 lists affected ranges: Go antrea.io/antrea >=0 =2.4.0 <2.4.3) Commands are suggestions: review each one before running it.
Loading voting…