Mattermost fails to preserve the redacted state of burn-on-read posts during deletion
CVE-2026-2578GHSA-3rhr-jr63-hwq5
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/mattermost/mattermost/server/v8 8.0.0-20260127062706-c6b205f0d770; github.com/mattermost/mattermost-server 11.3.1, 11.2.3, 10.11.11, 5.3.2-0.20260127062706-c6b205f0d770), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/mattermost/mattermost/server/v8
- Affected
- < 8.0.0-20260127062706-c6b205f0d770
- Fixed in
- 8.0.0-20260127062706-c6b205f0d770
Go github.com/mattermost/mattermost-server
- Affected
- < 5.3.2-0.20260127062706-c6b205f0d770>= 10.11.0-rc1, < 10.11.11>= 11.2.0-rc1, < 11.2.3>= 11.3.0-rc1, < 11.3.1
- Fixed in
- 11.3.1, 10.11.11, 11.2.3, 5.3.2-0.20260127062706-c6b205f0d770
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-3rhr-jr63-hwq5 lists affected ranges: Go github.com/mattermost/mattermost/server/v8 >=0 =0 =10.11.0-rc1 =11.2.0-rc1 =11.3.0-rc1 <11.3.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 4.3 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
- EPSS
- CVE-2026-2578: 0.23% estimated exploitation activity in the next 30 days; percentile 14.26 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Mattermost versions 11.3.x <= 11.3.0 fail to preserve the redacted state of burn-on-read posts during deletion which allows channel members to access unrevealed burn-on-read message contents via the WebSocket post deletion event. Mattermost Advisory ID: MMSA-2026-00579
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-3rhr-jr63-hwq5
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-2578 Advisory: Mattermost fails to preserve the redacted state of burn-on-read posts during deletion IDs: CVE-2026-2578, GHSA-3rhr-jr63-hwq5 Record: https://patchnext.com/advisories/cve-2026-2578 (revision 1, source checked 26 Oct 2026, 15:18 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/mattermost/mattermost/server/v8 8.0.0-20260127062706-c6b205f0d770; github.com/mattermost/mattermost-server 11.3.1, 11.2.3, 10.11.11, 5.3.2-0.20260127062706-c6b205f0d770. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/mattermost/mattermost/server/v8: affected < 8.0.0-20260127062706-c6b205f0d770; fixed in 8.0.0-20260127062706-c6b205f0d770 - Go github.com/mattermost/mattermost-server: affected < 5.3.2-0.20260127062706-c6b205f0d770; >= 10.11.0-rc1, < 10.11.11; >= 11.2.0-rc1, < 11.2.3; >= 11.3.0-rc1, < 11.3.1; fixed in 11.3.1, 10.11.11, 11.2.3, 5.3.2-0.20260127062706-c6b205f0d770 ## Suggested inspection (read-only) - Go github.com/mattermost/mattermost/server/v8: check the installed version with your package manager. - Go github.com/mattermost/mattermost-server: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/mattermost/mattermost/server/v8, github.com/mattermost/mattermost-server. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-3rhr-jr63-hwq5 (GitHub-reviewed advisory GHSA-3rhr-jr63-hwq5 lists affected ranges: Go github.com/mattermost/mattermost/server/v8 >=0 =0 =10.11.0-rc1 =11.2.0-rc1 =11.3.0-rc1 <11.3.1) Commands are suggestions: review each one before running it.
Loading voting…