Unauthenticated Spree Commerce users can access all guest addresses
CVE-2026-25758GHSA-87fh-rc96-6fr6
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (spree_api 5.3.2, 5.2.7, 5.1.10, 5.0.8, 4.10.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
RubyGems spree_api
- Affected
- < 4.10.3>= 5.0.0, < 5.0.8>= 5.1.0, < 5.1.10>= 5.2.0, < 5.2.7>= 5.3.0, < 5.3.2
- Fixed in
- 5.3.2, 5.2.7, 5.1.10, 4.10.3, 5.0.8
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-87fh-rc96-6fr6 lists affected ranges: RubyGems spree_api >=0 =5.0.0 =5.1.0 =5.2.0 =5.3.0 <5.3.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 7.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N/E:P · score source
- EPSS
- CVE-2026-25758: 0.67% estimated exploitation activity in the next 30 days; percentile 52.09 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary A critical IDOR vulnerability exists in Spree Commerce's guest checkout flow that allows any guest user to bind arbitrary guest addresses to their order by manipulating address ID parameters. This enables unauthorized access to other guests' personally identifiable information (PII) including names, addresses and phone numbers. The vulnerability bypasses existing ownership validation checks and affects all guest checkout transactions. Impact This issue may lead to disclosure of PII of guest users (including names, addresses and phone numbers). Unauthenticated users can access all guest addresses (GHSL-2026-027) The vulnerability stems from incomplete authorization validation in Spree's checkout address assignment logic. While nested address attributes (billaddressattributes[id] and shipaddressattributes[id]) are properly validated through validateaddressownership, plain ID parameters (billaddressid and shipaddressid) bypass this check entirely. Since Spree's address IDs are…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-87fh-rc96-6fr6
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-25758 Advisory: Unauthenticated Spree Commerce users can access all guest addresses IDs: CVE-2026-25758, GHSA-87fh-rc96-6fr6 Record: https://patchnext.com/advisories/cve-2026-25758 (revision 1, source checked 26 Oct 2026, 15:51 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: spree_api 5.3.2, 5.2.7, 5.1.10, 5.0.8, 4.10.3. A vendor fix does not mean a deployment is fixed. ## Affected components - RubyGems spree_api: affected < 4.10.3; >= 5.0.0, < 5.0.8; >= 5.1.0, < 5.1.10; >= 5.2.0, < 5.2.7; >= 5.3.0, < 5.3.2; fixed in 5.3.2, 5.2.7, 5.1.10, 4.10.3, 5.0.8 ## Suggested inspection (read-only) - RubyGems spree_api: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on spree_api. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-87fh-rc96-6fr6 (GitHub-reviewed advisory GHSA-87fh-rc96-6fr6 lists affected ranges: RubyGems spree_api >=0 =5.0.0 =5.1.0 =5.2.0 =5.3.0 <5.3.2) Commands are suggestions: review each one before running it.
Loading voting…