Indico Affected by Cross-Site-Scripting via material uploads
CVE-2026-25739GHSA-jxc4-54g3-j7vp
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (indico 3.3.10), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI indico
- Affected
- < 3.3.10
- Fixed in
- 3.3.10
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-jxc4-54g3-j7vp lists affected ranges: PyPI indico >=0 <3.3.10 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-jxc4-54g3-j7vp lists affected ranges: PyPI indico >=0 <3.3.10
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.4 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- EPSS
- CVE-2026-25739: 0.19% estimated exploitation activity in the next 30 days; percentile 9.11 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact There is a Cross-Site-Scripting vulnerability when uploading certain file types as materials. Patches You should to update to Indico 3.3.10 as soon as possible. See the docs for instructions on how to update. Please be aware that to apply the fix itself updating is sufficient, but to benefit from the strict Content-Security-Policy we now apply by default for file downloads, you need to update your webserver config in case you use nginx with Indico's STATICFILEMETHOD set to xaccelredirect and add the following line to the .xsf/indico/ location block (you can consult the Indico setup documentation for the full configuration snippet): Workarounds - Use your webserver config to apply a strict CSP for material download endpoints. - Only let trustworthy users create content (including material uploads, which speakers can typically do as well) on Indico. For more information If you have any questions or comments about this advisory: - Open a thread in our forum - Email us privately…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-jxc4-54g3-j7vp
- Revision 1 · created ·
Published from osv record GHSA-jxc4-54g3-j7vp
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-25739 Advisory: Indico Affected by Cross-Site-Scripting via material uploads IDs: CVE-2026-25739, GHSA-jxc4-54g3-j7vp Record: https://patchnext.com/advisories/cve-2026-25739 (revision 2, source checked 26 Oct 2026, 13:36 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: indico 3.3.10. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI indico: affected < 3.3.10; fixed in 3.3.10 ## Suggested inspection (read-only) - `python -m pip show indico`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on indico. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-jxc4-54g3-j7vp (OSV record GHSA-jxc4-54g3-j7vp lists affected ranges: PyPI indico >=0 <3.3.10 (fixed)) - Verified: https://github.com/advisories/GHSA-jxc4-54g3-j7vp (GitHub-reviewed advisory GHSA-jxc4-54g3-j7vp lists affected ranges: PyPI indico >=0 <3.3.10) Commands are suggestions: review each one before running it.
Loading voting…