Indico has Server-Side Request Forgery (SSRF) in multiple places
CVE-2026-25738GHSA-f47c-3c5w-v7p4
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (indico 3.3.10), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI indico
- Affected
- < 3.3.10
- Fixed in
- 3.3.10
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-f47c-3c5w-v7p4 lists affected ranges: PyPI indico >=0 <3.3.10 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-f47c-3c5w-v7p4 lists affected ranges: PyPI indico >=0 <3.3.10
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N · score source
- EPSS
- CVE-2026-25738: 0.27% estimated exploitation activity in the next 30 days; percentile 19.08 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Indico makes outgoing requests to user-provides URLs in various places. This is mostly intentional and part of Indico's functionality, but of course it is never intended to let you access "special" targets such as localhost or cloud metadata endpoints. Patches You should to update to Indico 3.3.10 as soon as possible. See the docs for instructions on how to update. Workarounds If you do not have IPs that expose sensitive data without authentication (typically because you do not host Indico on AWS), this vulnerability doesn't impact you and you can ignore it (but please upgrade anyway). Also, only event organizers can access endpoints where SSRF could be used to actually see the data returned by such a request. So if you trust your event organizers, the risk is also very limited. For additional security, both before and after patching, you could also use the common proxy-related environment variables (in particular httpproxy and httpsproxy) to force outgoing requests to go…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-f47c-3c5w-v7p4
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-f47c-3c5w-v7p4
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-25738 Advisory: Indico has Server-Side Request Forgery (SSRF) in multiple places IDs: CVE-2026-25738, GHSA-f47c-3c5w-v7p4 Record: https://patchnext.com/advisories/cve-2026-25738 (revision 3, source checked 26 Oct 2026, 13:36 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: indico 3.3.10. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI indico: affected < 3.3.10; fixed in 3.3.10 ## Suggested inspection (read-only) - `python -m pip show indico`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on indico. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-f47c-3c5w-v7p4 (OSV record GHSA-f47c-3c5w-v7p4 lists affected ranges: PyPI indico >=0 <3.3.10 (fixed)) - Verified: https://github.com/advisories/GHSA-f47c-3c5w-v7p4 (GitHub-reviewed advisory GHSA-f47c-3c5w-v7p4 lists affected ranges: PyPI indico >=0 <3.3.10) Commands are suggestions: review each one before running it.
Loading voting…