Skip to content

← Actionable
High, CVSS 8.1

Cloudreve is vulnerable to Account Takeover via Weak Cryptographic Token Generation (Insecure PRNG Seeding)

CVE-2026-25726GHSA-f8xp-wvcx-p6f4

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/cloudreve/Cloudreve/v4 4.0.0-20260205113604-ec9fdd33bc54), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.1 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2026-25726: 0.39% estimated exploitation activity in the next 30 days; percentile 33.27 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact This vulnerability affects Cloudreve instances that were first deployed/initialized with versions prior to V4.10.0. The application uses the weak pseudo-random number generator math/rand seeded with time.Now().UnixNano() to generate critical security secrets, including the secretkey, and hashidsalt. These secrets are generated upon first startup and persisted in the database. An attacker can exploit this by obtaining the administrator's account creation time (via public API endpoints) to narrow the search window for the PRNG seed, and use known hashid to validate the seed. By brute-forcing the seed (demonstrated to take <3 hours on general consumer PC), an attacker can predict the secretkey. This allows them to forge valid JSON Web Tokens (JWTs) for any user, including administrators, leading to full account takeover and privilege escalation. Note: Servers running V4.10.0+ are still vulnerable if they were originally installed using an older version, as the weak secrets…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-f8xp-wvcx-p6f4

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-25726

Advisory: Cloudreve is vulnerable to Account Takeover via Weak Cryptographic Token Generation (Insecure PRNG Seeding)
IDs: CVE-2026-25726, GHSA-f8xp-wvcx-p6f4
Record: https://patchnext.com/advisories/cve-2026-25726 (revision 1, source checked 26 Oct 2026, 15:19 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/cloudreve/Cloudreve/v4 4.0.0-20260205113604-ec9fdd33bc54. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/cloudreve/Cloudreve/v4: affected < 4.0.0-20260205113604-ec9fdd33bc54; fixed in 4.0.0-20260205113604-ec9fdd33bc54

## Suggested inspection (read-only)
- Go github.com/cloudreve/Cloudreve/v4: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/cloudreve/Cloudreve/v4.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-f8xp-wvcx-p6f4 (GitHub-reviewed advisory GHSA-f8xp-wvcx-p6f4 lists affected ranges: Go github.com/cloudreve/Cloudreve/v4 >=0 <4.0.0-20260205113604-ec9fdd33bc54)

Commands are suggestions: review each one before running it.

Loading voting…