Skip to content

← Actionable
High, CVSS 8.4

Rancher Extensions have arbitrary file access via path traversal

CVE-2026-25705GHSA-5v3h-x4wf-5c35

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/rancher/rancher 2.14.1, 2.13.5, 2.12.9, 2.11.13), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Go github.com/rancher/rancher

    Affected
    >= 2.14.0, < 2.14.1>= 2.13.0, < 2.13.5>= 2.12.0, < 2.12.9>= 2.10.11, < 2.11.13
    Fixed in
    2.11.13, 2.12.9, 2.14.1, 2.13.5

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.4 · CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:H/I:H/A:H
EPSS
  • CVE-2026-25705: 0.37% estimated exploitation activity in the next 30 days; percentile 30.79 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact A vulnerability has been identified in Rancher's Extensions where malicious code can be injected in Rancher through a path traversal in the compressedEndpoint field inside a UIPlugin deployment. A malicious UI extension could abuse that to: - Overwrite Rancher binaries or configuration to inject code. - Write to /var/lib/rancher/ to tamper with cluster state. - If hostPath volumes are mounted, write to the host node filesystem. - Use this issue to chain with other attack vectors. By default only the administrator can deploy UI extensions, unless permissions are granted to other users. It's always recommended to only install extensions that come from sources trusted by the user. Please consult the associated MITRE CAPEC-126 - Technique - Path Traversal for further information about this category of attack. Patches This vulnerability is addressed by ensuring that: - The file defined by the UI Plugin CR's compressedEndpoint has to be created inside the cache directory and cannot…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-5v3h-x4wf-5c35

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-25705

Advisory: Rancher Extensions have arbitrary file access via path traversal
IDs: CVE-2026-25705, GHSA-5v3h-x4wf-5c35
Record: https://patchnext.com/advisories/cve-2026-25705 (revision 1, source checked 26 Oct 2026, 15:22 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/rancher/rancher 2.14.1, 2.13.5, 2.12.9, 2.11.13. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/rancher/rancher: affected >= 2.14.0, < 2.14.1; >= 2.13.0, < 2.13.5; >= 2.12.0, < 2.12.9; >= 2.10.11, < 2.11.13; fixed in 2.11.13, 2.12.9, 2.14.1, 2.13.5

## Suggested inspection (read-only)
- Go github.com/rancher/rancher: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/rancher/rancher.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-5v3h-x4wf-5c35 (GitHub-reviewed advisory GHSA-5v3h-x4wf-5c35 lists affected ranges: Go github.com/rancher/rancher >=2.14.0 =2.13.0 =2.12.0 =2.10.11 <2.11.13)

Commands are suggestions: review each one before running it.

Loading voting…