Skip to content

← Actionable
Medium, CVSS 6.1amended

client-certificate-auth Vulnerable to Open Redirect via Host Header Injection in HTTP-to-HTTPS redirect

CVE-2026-25651GHSA-m4w9-gch5-c2g4

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (client-certificate-auth 1.0.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
EPSS
  • CVE-2026-25651: 0.18% estimated exploitation activity in the next 30 days; percentile 7.97 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Versions 0.2.1 and 0.3.0 of client-certificate-auth contain an open redirect vulnerability. The middleware unconditionally redirects HTTP requests to HTTPS using the unvalidated Host header, allowing an attacker to redirect users to arbitrary domains. Vulnerable Code Attack Scenario 1. Attacker crafts a link: http://vulnerable-app.example.com/login 2. When victim clicks, attacker intercepts and injects header: Host: attacker.com 3. Server responds: 302 Found → https://attacker.com/login 4. Victim is redirected to attacker-controlled site Impact - Phishing: Attackers can use trusted domain links to redirect victims to credential-harvesting pages - OAuth/SSO Token Theft: In authentication flows, authorization codes or tokens may leak via redirect - Referer Leakage: Sensitive URL parameters may be exposed to attacker domains via the Referer header - Cache Poisoning: In deployments with shared caches, malicious redirects may be cached and served to other users Exploitability…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-m4w9-gch5-c2g4

  2. Revision 1 · created ·

    Published from osv record GHSA-m4w9-gch5-c2g4

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-25651

Advisory: client-certificate-auth Vulnerable to Open Redirect via Host Header Injection in HTTP-to-HTTPS redirect
IDs: CVE-2026-25651, GHSA-m4w9-gch5-c2g4
Record: https://patchnext.com/advisories/cve-2026-25651 (revision 2, source checked 26 Oct 2026, 12:42 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: client-certificate-auth 1.0.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm client-certificate-auth: affected >= 0.2.1, < 1.0.0; fixed in 1.0.0

## Suggested inspection (read-only)
- `npm ls client-certificate-auth --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on client-certificate-auth.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-m4w9-gch5-c2g4 (OSV record GHSA-m4w9-gch5-c2g4 lists affected ranges: npm client-certificate-auth >=0.2.1 <1.0.0 (fixed))
- Verified: https://github.com/advisories/GHSA-m4w9-gch5-c2g4 (GitHub-reviewed advisory GHSA-m4w9-gch5-c2g4 lists affected ranges: npm client-certificate-auth >=0.2.1 <1.0.0)

Commands are suggestions: review each one before running it.

Loading voting…