Requests has Insecure Temp File Reuse in its extract_zipped_paths() utility function
CVE-2026-25645GHSA-gc5v-m9x4-r6x2
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (requests 2.33.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI requests
- Affected
- < 2.33.0
- Fixed in
- 2.33.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-gc5v-m9x4-r6x2 lists affected ranges: PyPI requests >=0 <2.33.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-gc5v-m9x4-r6x2 lists affected ranges: PyPI requests >=0 <2.33.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 4.4 · CVSS:3.1/AV:L/AC:H/PR:L/UI:R/S:U/C:N/I:H/A:N
- EPSS
- CVE-2026-25645: 0.19% estimated exploitation activity in the next 30 days; percentile 8.65 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact The requests.utils.extractzippedpaths() utility function uses a predictable filename when extracting files from zip archives into the system temporary directory. If the target file already exists, it is reused without validation. A local attacker with write access to the temp directory could pre-create a malicious file that would be loaded in place of the legitimate one. Affected usages Standard usage of the Requests library is not affected by this vulnerability. Only applications that call extractzippedpaths() directly are impacted. Remediation Upgrade to at least Requests 2.33.0, where the library now extracts files to a non-deterministic location. If developers are unable to upgrade, they can set TMPDIR in their environment to a directory with restricted write access.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-gc5v-m9x4-r6x2
- Revision 1 · created ·
Published from osv record GHSA-gc5v-m9x4-r6x2
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-25645 Advisory: Requests has Insecure Temp File Reuse in its extract_zipped_paths() utility function IDs: CVE-2026-25645, GHSA-gc5v-m9x4-r6x2 Record: https://patchnext.com/advisories/cve-2026-25645 (revision 2, source checked 26 Oct 2026, 13:40 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: requests 2.33.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI requests: affected < 2.33.0; fixed in 2.33.0 ## Suggested inspection (read-only) - `python -m pip show requests`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on requests. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-gc5v-m9x4-r6x2 (OSV record GHSA-gc5v-m9x4-r6x2 lists affected ranges: PyPI requests >=0 <2.33.0 (fixed)) - Verified: https://github.com/advisories/GHSA-gc5v-m9x4-r6x2 (GitHub-reviewed advisory GHSA-gc5v-m9x4-r6x2 lists affected ranges: PyPI requests >=0 <2.33.0) Commands are suggestions: review each one before running it.
Loading voting…