Skip to content

← Actionable
High, CVSS 7.1amended

Pydantic AI has Stored XSS via Path Traversal in Web UI CDN URL

CVE-2026-25640GHSA-wjp5-868j-wqv7

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (pydantic-ai 1.51.0; pydantic-ai-slim 1.51.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:L/A:N
EPSS
  • CVE-2026-25640: 0.37% estimated exploitation activity in the next 30 days; percentile 31.14 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary A Path Traversal vulnerability in the Pydantic AI web UI allows an attacker to serve arbitrary JavaScript in the context of the application by crafting a malicious URL. If a victim clicks the link or visits it via an iframe, attacker-controlled code executes in their browser, enabling theft of chat history and other client-side data. This vulnerability only affects applications that use: - Agent.toweb to serve a chat interface - clai web to serve a chat interface from the CLI These are typically run locally (on localhost), but may also be deployed on a remote server. Description The web UI serves its frontend HTML by fetching it from a CDN. In affected versions, the CDN URL is constructed using a version query parameter from the request URL. This parameter is not validated, allowing path traversal sequences that cause the server to fetch and serve attacker-controlled HTML/JavaScript from an arbitrary source on the same CDN, instead of the legitimate chat UI package. Who Is…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-wjp5-868j-wqv7

  2. Revision 1 · created ·

    Published from osv record GHSA-wjp5-868j-wqv7

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-25640

Advisory: Pydantic AI has Stored XSS via Path Traversal in Web UI CDN URL
IDs: CVE-2026-25640, GHSA-wjp5-868j-wqv7
Record: https://patchnext.com/advisories/cve-2026-25640 (revision 2, source checked 26 Oct 2026, 13:36 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: pydantic-ai 1.51.0; pydantic-ai-slim 1.51.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI pydantic-ai: affected >= 1.34.0, < 1.51.0; fixed in 1.51.0
- PyPI pydantic-ai-slim: affected >= 1.34.0, < 1.51.0; fixed in 1.51.0

## Suggested inspection (read-only)
- `python -m pip show pydantic-ai`: prints the installed version. Run with the environment that serves production active.
- `python -m pip show pydantic-ai-slim`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on pydantic-ai, pydantic-ai-slim.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-wjp5-868j-wqv7 (OSV record GHSA-wjp5-868j-wqv7 lists affected ranges: PyPI pydantic-ai >=1.34.0 =1.34.0 <1.51.0 (fixed))
- Verified: https://github.com/advisories/GHSA-wjp5-868j-wqv7 (GitHub-reviewed advisory GHSA-wjp5-868j-wqv7 lists affected ranges: PyPI pydantic-ai >=1.34.0 =1.34.0 <1.51.0)

Commands are suggestions: review each one before running it.

Loading voting…