Skip to content

← Actionable
Medium, CVSS 6.1

Navidrome has XSS via comment from song metadata

CVE-2026-25578GHSA-rh3r-8pxm-hg4w

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/navidrome/navidrome 0.60.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.1 · CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:L/A:N
EPSS
  • CVE-2026-25578: 0.34% estimated exploitation activity in the next 30 days; percentile 27.24 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary An XSS vulnerability in the frontend allows a malicious attacker to inject code through the comment metadata of a song to exfiltrate user credentials. An attacker's maliciously crafted song has to be added to Navidrome to exploit the vulnerability. Details The frontend is using React. In various places, the code uses the dangerouslySetInnerHTML escape hatch to set the content of an HTML element. In some places, the value is first sanitized by removing anything looking like an HTML tag. In at least one place the value is used as is, thus leading to the XSS vulnerability. In MultiLineTextField component, the input is split into lines and rendered through the dangerouslySetInnerHTML property. This component is then used in the SongInfo and AlbumInfo components, when rendering the comment of the song or album. The contents of the comments field is taken verbatim from the metadata of a song, such as the VORBIS COMMENT comment of a FLAC file. By crafting the contents of the comment…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-rh3r-8pxm-hg4w

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-25578

Advisory: Navidrome has XSS via comment from song metadata
IDs: CVE-2026-25578, GHSA-rh3r-8pxm-hg4w
Record: https://patchnext.com/advisories/cve-2026-25578 (revision 1, source checked 26 Oct 2026, 15:14 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/navidrome/navidrome 0.60.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/navidrome/navidrome: affected < 0.60.0; fixed in 0.60.0

## Suggested inspection (read-only)
- Go github.com/navidrome/navidrome: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/navidrome/navidrome.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-rh3r-8pxm-hg4w (GitHub-reviewed advisory GHSA-rh3r-8pxm-hg4w lists affected ranges: Go github.com/navidrome/navidrome >=0 <0.60.0)

Commands are suggestions: review each one before running it.

Loading voting…