@isaacs/brace-expansion has Uncontrolled Resource Consumption
CVE-2026-25547GHSA-7h2j-956f-4vf2
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@isaacs/brace-expansion 5.0.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- <= 5.0.0
- Fixed in
- 5.0.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-7h2j-956f-4vf2 lists affected ranges: npm @isaacs/brace-expansion >=0 <5.0.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-7h2j-956f-4vf2 lists affected ranges: npm @isaacs/brace-expansion >=0 <=5.0.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-25547: 0.54% estimated exploitation activity in the next 30 days; percentile 45.36 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary @isaacs/brace-expansion is vulnerable to a Denial of Service (DoS) issue caused by unbounded brace range expansion. When an attacker provides a pattern containing repeated numeric brace ranges, the library attempts to eagerly generate every possible combination synchronously. Because the expansion grows exponentially, even a small input can consume excessive CPU and memory and may crash the Node.js process. Details The vulnerability occurs because @isaacs/brace-expansion expands brace expressions without any upper bound or complexity limit. Expansion is performed eagerly and synchronously, meaning the full result set is generated before returning control to the caller. For example, the following input: produces: This exponential growth can quickly overwhelm the event loop and heap memory, resulting in process termination. Proof of Concept The following script reliably triggers the issue. Create poc.js: Run it: The process will freeze and typically crash with an error such as:…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-7h2j-956f-4vf2
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-7h2j-956f-4vf2
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-25547 Advisory: @isaacs/brace-expansion has Uncontrolled Resource Consumption IDs: CVE-2026-25547, GHSA-7h2j-956f-4vf2 Record: https://patchnext.com/advisories/cve-2026-25547 (revision 3, source checked 26 Oct 2026, 12:42 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @isaacs/brace-expansion 5.0.1. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @isaacs/brace-expansion: affected <= 5.0.0; fixed in 5.0.1 ## Suggested inspection (read-only) - `npm ls @isaacs/brace-expansion --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @isaacs/brace-expansion. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-7h2j-956f-4vf2 (OSV record GHSA-7h2j-956f-4vf2 lists affected ranges: npm @isaacs/brace-expansion >=0 <5.0.1 (fixed)) - Verified: https://github.com/advisories/GHSA-7h2j-956f-4vf2 (GitHub-reviewed advisory GHSA-7h2j-956f-4vf2 lists affected ranges: npm @isaacs/brace-expansion >=0 <=5.0.0) Commands are suggestions: review each one before running it.
Loading voting…