@payloadcms/drizzle has SQL Injection in JSON/RichText Queries on PostgreSQL/SQLite Adapters
CVE-2026-25544GHSA-xx6w-jxg9-2wh8
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@payloadcms/drizzle 3.73.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 3.73.0
- Fixed in
- 3.73.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-xx6w-jxg9-2wh8 lists affected ranges: npm @payloadcms/drizzle >=0 <3.73.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-xx6w-jxg9-2wh8 lists affected ranges: npm @payloadcms/drizzle >=0 <3.73.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2026-25544: 0.83% estimated exploitation activity in the next 30 days; percentile 57.46 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact When querying JSON or richText fields, user input was directly embedded into SQL without escaping, enabling blind SQL Injection attacks. An unauthenticated attacker could extract sensitive data (emails, password reset tokens) and achieve full account takeover without password cracking. Users are affected if ALL of these are true: 1. Payload version < v3.73.0 2. Using a Drizzle-based database adapter (@payloadcms/drizzle as dependency): - @payloadcms/db-postgres - @payloadcms/db-vercel-postgres - @payloadcms/db-sqlite - @payloadcms/db-d1-sqlite 3. At least one accessible collection that has a type: 'json' or type: 'richText' field where access.read returns anything other than false (true or Where constraint) Users are NOT affected if: - Using @payloadcms/db-mongodb - No JSON or richText fields exist in any collection - All JSON/richText fields have access: { read: () = false } Patches Upgrade to Payload v3.73.0 or later. Workarounds If a project cannot upgrade immediately, add…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-xx6w-jxg9-2wh8
- Revision 2 · amended ·
Amended from osv record GHSA-xx6w-jxg9-2wh8
- Revision 1 · created ·
Published from ghsa record GHSA-xx6w-jxg9-2wh8
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-25544 Advisory: @payloadcms/drizzle has SQL Injection in JSON/RichText Queries on PostgreSQL/SQLite Adapters IDs: CVE-2026-25544, GHSA-xx6w-jxg9-2wh8 Record: https://patchnext.com/advisories/cve-2026-25544 (revision 3, source checked 26 Oct 2026, 12:42 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @payloadcms/drizzle 3.73.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @payloadcms/drizzle: affected < 3.73.0; fixed in 3.73.0 ## Suggested inspection (read-only) - `npm ls @payloadcms/drizzle --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @payloadcms/drizzle. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-xx6w-jxg9-2wh8 (GitHub-reviewed advisory GHSA-xx6w-jxg9-2wh8 lists affected ranges: npm @payloadcms/drizzle >=0 <3.73.0) - Verified: https://osv.dev/vulnerability/GHSA-xx6w-jxg9-2wh8 (OSV record GHSA-xx6w-jxg9-2wh8 lists affected ranges: npm @payloadcms/drizzle >=0 <3.73.0 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…