Skip to content

← Actionable
Medium, CVSS 5.5

jsonwebtoken has Type Confusion that leads to potential authorization bypass

CVE-2026-25537GHSA-h395-gr6q-cpjc

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (jsonwebtoken 10.3.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
5.5 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N/E:P · score source
EPSS
  • CVE-2026-25537: 0.50% estimated exploitation activity in the next 30 days; percentile 42.62 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary: It has been discovered that there is a Type Confusion vulnerability in jsonwebtoken, specifically, in its claim validation logic. When a standard claim (such as nbf or exp) is provided with an incorrect JSON type (Like a String instead of a Number), the library’s internal parsing mechanism marks the claim as “FailedToParse”. Crucially, the validation logic treats this “FailedToParse” state identically to “NotPresent”. This means that if a check is enabled (like: validatenbf = true), but the claim is not explicitly marked as required in requiredspecclaims, the library will skip the validation check entirely for the malformed claim, treating it as if it were not there. This allows attackers to bypass critical time-based security restrictions (like “Not Before” checks) and commit potential authentication and authorization bypasses. Details: The vulnerability stems from the interaction between the TryParse enum and the validate function in src/validation.rs. 1. The TryParse…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-h395-gr6q-cpjc

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-25537

Advisory: jsonwebtoken has Type Confusion that leads to potential authorization bypass
IDs: CVE-2026-25537, GHSA-h395-gr6q-cpjc
Record: https://patchnext.com/advisories/cve-2026-25537 (revision 1, source checked 26 Oct 2026, 15:39 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: jsonwebtoken 10.3.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- crates.io jsonwebtoken: affected < 10.3.0; fixed in 10.3.0

## Suggested inspection (read-only)
- crates.io jsonwebtoken: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on jsonwebtoken.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-h395-gr6q-cpjc (GitHub-reviewed advisory GHSA-h395-gr6q-cpjc lists affected ranges: crates.io jsonwebtoken >=0 <10.3.0)

Commands are suggestions: review each one before running it.

Loading voting…