Sandbox escape via infinite recursion and error objects
CVE-2026-25533GHSA-x39w-8vm5-5m3p
What to do
Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm enclave-vm
- Affected
- <= 2.7.0
- Fixed in
- no fixed version recorded
npm @enclave-vm/core
- Affected
- < 2.10.1
- Fixed in
- 2.10.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-x39w-8vm5-5m3p lists affected ranges: npm enclave-vm >=0 =0 <2.10.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-x39w-8vm5-5m3p lists affected ranges: npm enclave-vm >=0 =0 <2.10.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.4 · CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:N/SC:H/SI:H/SA:H · score source
- EPSS
- CVE-2026-25533: 0.26% estimated exploitation activity in the next 30 days; percentile 17.21 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Note: The npm package has moved to @enclave-vm/core (formerly enclave-vm). All fixed versions and guidance refer to @enclave-vm/core. Summary The existing layers of security in enclave-vm are insufficient: The AST sanitization can be bypassed with dynamic property accesses, the hardening of the error objects does not cover the peculiar behavior or the vm module and the function constructor access prevention can be side-stepped by leveraging host object references. Details There is a bug in Node.js (https://www.staicu.org/publications/usenixSec2023-SandDriller.pdf) that makes the vm module leak host references inside the vm module in case of infinite recursion. An attacker can exploit these to escape the sandbox. PoC The following on was tested on Node.js v24.12.0 and enclave-vm 2.7.0. Impact Sandbox escape and potential other escalations on FrontMCP/AgentFront/other Frontegg products.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-x39w-8vm5-5m3p
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-x39w-8vm5-5m3p
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-25533 Advisory: Sandbox escape via infinite recursion and error objects IDs: CVE-2026-25533, GHSA-x39w-8vm5-5m3p Record: https://patchnext.com/advisories/cve-2026-25533 (revision 3, source checked 26 Oct 2026, 12:42 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Partial vendor fix; fixed versions by package: @enclave-vm/core 2.10.1. A vendor fix does not mean a deployment is fixed. ## Affected components - npm enclave-vm: affected <= 2.7.0 - npm @enclave-vm/core: affected < 2.10.1; fixed in 2.10.1 ## Suggested inspection (read-only) - `npm ls enclave-vm --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. - `npm ls @enclave-vm/core --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on enclave-vm, @enclave-vm/core. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-x39w-8vm5-5m3p (OSV record GHSA-x39w-8vm5-5m3p lists affected ranges: npm enclave-vm >=0 =0 <2.10.1 (fixed)) - Verified: https://github.com/advisories/GHSA-x39w-8vm5-5m3p (GitHub-reviewed advisory GHSA-x39w-8vm5-5m3p lists affected ranges: npm enclave-vm >=0 =0 <2.10.1) Commands are suggestions: review each one before running it.
Loading voting…