Skip to content

← Actionable
Medium, CVSS 5.8amended

LangSmith Client SDK Affected by Server-Side Request Forgery via Tracing Header Injection

CVE-2026-25528GHSA-v34v-rq6j-cj6p

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (langsmith 0.4.6; langsmith 0.6.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm langsmith

    Affected
    >= 0.3.41, < 0.4.6
    Fixed in
    0.4.6
  • PyPI langsmith

    Affected
    >= 0.4.10, < 0.6.3
    Fixed in
    0.6.3

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:N/A:N
EPSS
  • CVE-2026-25528: 0.32% estimated exploitation activity in the next 30 days; percentile 25.07 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The LangSmith SDK's distributed tracing feature is vulnerable to Server-Side Request Forgery via malicious HTTP headers. An attacker can inject arbitrary apiurl values through the baggage header, causing the SDK to exfiltrate sensitive trace data to attacker-controlled endpoints. --- Description When using distributed tracing, the SDK parses incoming HTTP headers via RunTree.fromheaders() in Python or RunTree.fromHeaders() in Typescript. The baggage header can contain replica configurations including apiurl and apikey fields. Prior to the fix, these attacker-controlled values were accepted without validation. When a traced operation completes, the SDK's post() and patch() methods send run data to all configured replica URLs, including any injected by an attacker. --- Attack Vector 1. Attacker sends an HTTP request to a vulnerable service with a malicious baggage header: 2. The service parses the header via RunTree.fromheaders(), storing the attacker's URL 3. When the traced…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-v34v-rq6j-cj6p

  2. Revision 1 · created ·

    Published from osv record GHSA-v34v-rq6j-cj6p

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-25528

Advisory: LangSmith Client SDK Affected by Server-Side Request Forgery via Tracing Header Injection
IDs: CVE-2026-25528, GHSA-v34v-rq6j-cj6p
Record: https://patchnext.com/advisories/cve-2026-25528 (revision 2, source checked 26 Oct 2026, 12:42 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: langsmith 0.4.6; langsmith 0.6.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm langsmith: affected >= 0.3.41, < 0.4.6; fixed in 0.4.6
- PyPI langsmith: affected >= 0.4.10, < 0.6.3; fixed in 0.6.3

## Suggested inspection (read-only)
- `npm ls langsmith --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `python -m pip show langsmith`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on langsmith.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-v34v-rq6j-cj6p (OSV record GHSA-v34v-rq6j-cj6p lists affected ranges: PyPI langsmith >=0.4.10 =0.3.41 <0.4.6 (fixed))
- Verified: https://github.com/advisories/GHSA-v34v-rq6j-cj6p (GitHub-reviewed advisory GHSA-v34v-rq6j-cj6p lists affected ranges: PyPI langsmith >=0.4.10 =0.3.41 <0.4.6)

Commands are suggestions: review each one before running it.

Loading voting…