Skip to content

← Actionable
Medium, CVSS 5.3amended

changedetection.io is vulnerable to unauthenticated static path traversal

CVE-2026-25527GHSA-9jj8-v89v-xjvw

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (changedetection-io 0.53.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
EPSS
  • CVE-2026-25527: 1.03% estimated exploitation activity in the next 30 days; percentile 63.63 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The /static/<group/<filename route accepts group="..", which causes sendfromdirectory("static/..", filename) to execute. This moves the base directory up to /app/changedetectionio, enabling unauthenticated local file read of application source files (e.g., flaskapp.py). Severity is low information disclosure (C:L). Details The vulnerable code is in changedetectionio/flaskapp.py inside staticcontent(): The group sanitization allows dots, so group=".." passes validation. This results in sendfromdirectory("static/..", filename), effectively shifting the base directory to /app/changedetectionio and allowing reads of files in that directory. The route is unauthenticated, so any user can retrieve source files without logging in. Limitation: the route only matches /static/<group/<filename and rejects slashes inside filename, so it cannot traverse further to arbitrary system paths like /etc/passwd. It is limited to files inside the application package directory. PoC 1) Start an…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-9jj8-v89v-xjvw

  2. Revision 1 · created ·

    Published from osv record GHSA-9jj8-v89v-xjvw

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-25527

Advisory: changedetection.io is vulnerable to unauthenticated static path traversal
IDs: CVE-2026-25527, GHSA-9jj8-v89v-xjvw
Record: https://patchnext.com/advisories/cve-2026-25527 (revision 2, source checked 26 Oct 2026, 13:49 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: changedetection-io 0.53.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI changedetection-io: affected < 0.53.2; fixed in 0.53.2

## Suggested inspection (read-only)
- `python -m pip show changedetection-io`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on changedetection-io.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-9jj8-v89v-xjvw (OSV record GHSA-9jj8-v89v-xjvw lists affected ranges: PyPI changedetection-io >=0 <0.53.2 (fixed))
- Verified: https://github.com/advisories/GHSA-9jj8-v89v-xjvw (GitHub-reviewed advisory GHSA-9jj8-v89v-xjvw lists affected ranges: PyPI changedetection-io >=0 <0.53.2)

Commands are suggestions: review each one before running it.

Loading voting…