locutus is vulnerable to Prototype Pollution
CVE-2026-25521GHSA-rxrv-835q-v5mh
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (locutus 2.0.39), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm locutus
- Affected
- >= 2.0.12, < 2.0.39
- Fixed in
- 2.0.39
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-rxrv-835q-v5mh lists affected ranges: npm locutus >=2.0.12 <2.0.39
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-rxrv-835q-v5mh lists affected ranges: npm locutus >=2.0.12 <2.0.39 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 9.4 · CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H · score source
- EPSS
- CVE-2026-25521: 0.31% estimated exploitation activity in the next 30 days; percentile 24.44 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary A Prototype Pollution vulnerability exists in the the npm package locutus (2.0.12). Despite a previous fix that attempted to mitigate Prototype Pollution by checking whether user input contained a forbidden key, it is still possible to pollute Object.prototype via a crafted input using String.prototype. This issue was fixed in version 2.0.39. Details The vulnerability resides in line 77 to 79 of https://github.com/locutusjs/locutus/blob/main/src/php/strings/parsestr.js where includes() function is used to check whether user provided input contain forbidden strings. PoC Steps to reproduce 1. Install latest version of locutus using npm install or cloning from git 2. Run the following code snippet: Expected behavior Prototype Pollution should be prevented and {} should not gain new properties. This should be printed on the console: Actual behavior Object.prototype is polluted This is printed on the console: Impact This is a Prototype Pollution vulnerability, which can have…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 4 · amended ·
Amended from ghsa record GHSA-rxrv-835q-v5mh
- Revision 3 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 2 · amended ·
Amended from osv record GHSA-rxrv-835q-v5mh
- Revision 1 · created ·
Published from ghsa record GHSA-rxrv-835q-v5mh
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-25521 Advisory: locutus is vulnerable to Prototype Pollution IDs: CVE-2026-25521, GHSA-rxrv-835q-v5mh Record: https://patchnext.com/advisories/cve-2026-25521 (revision 4, source checked 26 Oct 2026, 13:06 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: locutus 2.0.39. A vendor fix does not mean a deployment is fixed. ## Affected components - npm locutus: affected >= 2.0.12, < 2.0.39; fixed in 2.0.39 ## Suggested inspection (read-only) - `npm ls locutus --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on locutus. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-rxrv-835q-v5mh (GitHub-reviewed advisory GHSA-rxrv-835q-v5mh lists affected ranges: npm locutus >=2.0.12 <2.0.39) - Verified: https://osv.dev/vulnerability/GHSA-rxrv-835q-v5mh (OSV record GHSA-rxrv-835q-v5mh lists affected ranges: npm locutus >=2.0.12 <2.0.39 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…