Skip to content

← Actionable
Medium, CVSS 5.1amended

Wagtail has improper permission handling on admin preview endpoints

CVE-2026-25517GHSA-4qvv-g3vr-m348

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (wagtail 7.3, 7.2.2, 7.1.3, 7.0.4, 6.3.6), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI wagtail

    Affected
    < 6.3.6>= 6.4rc1, <= 7.0.3>= 7.1rc1, <= 7.1.2>= 7.2rc1, <= 7.2.1>= 7.3rc1, <= 7.3rc1
    Fixed in
    6.3.6, 7.3, 7.2.2, 7.1.3, 7.0.4

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
5.1 · CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-25517: 0.38% estimated exploitation activity in the next 30 days; percentile 32.56 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Due to a missing permission check on the preview endpoints, a user with access to the Wagtail admin and knowledge of a model's fields can craft a form submission to obtain a preview rendering of any page, snippet or site setting object for which previews are enabled, consisting of any data of the user's choosing. The existing data of the object itself is not exposed, but depending on the nature of the template being rendered, this may expose other database contents that would otherwise only be accessible to users with edit access over the model. The vulnerability is not exploitable by an ordinary site visitor without access to the Wagtail admin. Patches Patched versions have been released as Wagtail 6.3.6, 7.0.4, 7.1.3 and 7.2.2. The new 7.3 feature release also incorporates this fix. Workarounds No workaround is available. Acknowledgements Many thanks to @thxtech for reporting this issue. For more information If there are any questions or comments about this advisory: - Visit…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-4qvv-g3vr-m348

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-4qvv-g3vr-m348

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-25517

Advisory: Wagtail has improper permission handling on admin preview endpoints
IDs: CVE-2026-25517, GHSA-4qvv-g3vr-m348
Record: https://patchnext.com/advisories/cve-2026-25517 (revision 3, source checked 26 Oct 2026, 13:36 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: wagtail 7.3, 7.2.2, 7.1.3, 7.0.4, 6.3.6. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI wagtail: affected < 6.3.6; >= 6.4rc1, <= 7.0.3; >= 7.1rc1, <= 7.1.2; >= 7.2rc1, <= 7.2.1; >= 7.3rc1, <= 7.3rc1; fixed in 6.3.6, 7.3, 7.2.2, 7.1.3, 7.0.4

## Suggested inspection (read-only)
- `python -m pip show wagtail`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on wagtail.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-4qvv-g3vr-m348 (OSV record GHSA-4qvv-g3vr-m348 lists affected ranges: PyPI wagtail >=0 =6.4rc1 =7.1rc1 =7.2rc1 =7.3rc1 <7.3 (fixed))
- Verified: https://github.com/advisories/GHSA-4qvv-g3vr-m348 (GitHub-reviewed advisory GHSA-4qvv-g3vr-m348 lists affected ranges: PyPI wagtail >=0 =6.4rc1 =7.1rc1 =7.2rc1 =7.3rc1 <=7.3rc1)

Commands are suggestions: review each one before running it.

Loading voting…