Skip to content

← Actionable
Medium, CVSS 6.1amended

NiceGUI's XSS vulnerability in ui.markdown() allows arbitrary JavaScript execution through unsanitized HTML content

CVE-2026-25516GHSA-v82v-c5x8-w282

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (nicegui 3.7.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI nicegui

    Affected
    <= 3.6.1
    Fixed in
    3.7.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
EPSS
  • CVE-2026-25516: 0.28% estimated exploitation activity in the next 30 days; percentile 20.13 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Description The ui.markdown() component uses the markdown2 library to convert markdown content to HTML, which is then rendered via innerHTML. By default, markdown2 allows raw HTML to pass through unchanged. This means that if an application renders user-controlled content through ui.markdown(), an attacker can inject malicious HTML containing JavaScript event handlers. Unlike other NiceGUI components that render HTML (ui.html(), ui.chatmessage(), ui.interactiveimage()), the ui.markdown() component does not provide or require a sanitize parameter, leaving applications vulnerable to XSS attacks. Proof of Concept When this page loads, the JavaScript in the onerror handler executes, potentially allowing an attacker to: - Steal session cookies or authentication tokens - Perform actions on behalf of the user - Redirect users to malicious sites - Modify page content Impact Applications that render user-provided content through ui.markdown() are vulnerable to stored or reflected XSS attacks.…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-v82v-c5x8-w282

  2. Revision 1 · created ·

    Published from osv record GHSA-v82v-c5x8-w282

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-25516

Advisory: NiceGUI's XSS vulnerability in ui.markdown() allows arbitrary JavaScript execution through unsanitized HTML content
IDs: CVE-2026-25516, GHSA-v82v-c5x8-w282
Record: https://patchnext.com/advisories/cve-2026-25516 (revision 2, source checked 26 Oct 2026, 13:36 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: nicegui 3.7.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI nicegui: affected <= 3.6.1; fixed in 3.7.0

## Suggested inspection (read-only)
- `python -m pip show nicegui`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on nicegui.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-v82v-c5x8-w282 (OSV record GHSA-v82v-c5x8-w282 lists affected ranges: PyPI nicegui >=0 <3.7.0 (fixed))
- Verified: https://github.com/advisories/GHSA-v82v-c5x8-w282 (GitHub-reviewed advisory GHSA-v82v-c5x8-w282 lists affected ranges: PyPI nicegui >=0 <=3.6.1)

Commands are suggestions: review each one before running it.

Loading voting…