CI4MS Vulnerable to User Email Enumeration via Password Reset Flow
CVE-2026-25509GHSA-654x-9q7r-g966
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (ci4-cms-erp/ci4ms 0.28.5.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist ci4-cms-erp/ci4ms
- Affected
- < 0.28.5.0
- Fixed in
- 0.28.5.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-654x-9q7r-g966 lists affected ranges: Packagist ci4-cms-erp/ci4ms >=0 <0.28.5.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
- EPSS
- CVE-2026-25509: 0.39% estimated exploitation activity in the next 30 days; percentile 32.82 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary The authentication implementation in CI4MS is vulnerable to email enumeration. An unauthenticated attacker can determine whether an email address is registered in the system by analyzing the application's response during the password reset process. Vulnerability Details - The password reset flow returns different responses based on whether the provided email address exists in the database or not. - If the email is registered, the system typically returns a success message (e.g., "Password reset link has been sent"). If the email is not registered, the system returns an error message (e.g., "User not found" or a different HTTP status code). This discrepancy allows attackers to programmatically "enumerate" or confirm valid user emails, which can then be used for targeted phishing attacks or brute-force attempts. Steps to Reproduce 1. Navigate to the password reset page of the CI4MS installation. 2. Enter an email address that you know is not registered (e.g.,…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-654x-9q7r-g966
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-25509 Advisory: CI4MS Vulnerable to User Email Enumeration via Password Reset Flow IDs: CVE-2026-25509, GHSA-654x-9q7r-g966 Record: https://patchnext.com/advisories/cve-2026-25509 (revision 1, source checked 26 Oct 2026, 14:38 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: ci4-cms-erp/ci4ms 0.28.5.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist ci4-cms-erp/ci4ms: affected < 0.28.5.0; fixed in 0.28.5.0 ## Suggested inspection (read-only) - Packagist ci4-cms-erp/ci4ms: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on ci4-cms-erp/ci4ms. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-654x-9q7r-g966 (GitHub-reviewed advisory GHSA-654x-9q7r-g966 lists affected ranges: Packagist ci4-cms-erp/ci4ms >=0 <0.28.5.0) Commands are suggestions: review each one before running it.
Loading voting…