Skip to content

← Actionable
Critical, CVSS 9.8amended

Bambuddy Uses Hardcoded Secret Key + Many API Endpoints do not Require Authentication

CVE-2026-25505GHSA-gc24-px2r-5qmf

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (bambuddy 0.1.7), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI bambuddy

    Affected
    < 0.1.7
    Fixed in
    0.1.7

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2026-25505: 0.81% estimated exploitation activity in the next 30 days; percentile 56.94 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary 1. A hardcoded secret key used for signing JWTs is checked into source code 2. ManyAPI routes do not check authentication Details I am using the publicly available docker image at ghcr.io/maziggy/bambuddy 1. Hardcoded JWT Secret Key https://github.com/maziggy/bambuddy/blob/a9bb8ed8239602bf08a9914f85a09eeb2bf13d15/backend/app/core/auth.py#L28 <details <summaryCopying the Authorization token from a request via browser networking tools into JWT.io confirms the token is signed with this key</summary <img width="1591" height="937" alt="image" src="https://github.com/user-attachments/assets/fd6e805a-9380-438f-a412-623660fa3f5a" / </details Any attacker can: 1. Forge valid JWT tokens for any user 2. Bypass authentication entirely 3. Gain full administrative access to any Bambuddy instance using the default key Steps to Reproduce: 1. Run an instance of BamBuddy 2. Create admin user 3. Forge and use JWT: 2. Most API Routes do not check Auth While investigating the JWT forgery, I…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-gc24-px2r-5qmf

  2. Revision 2 · amended ·

    Amended from osv record GHSA-gc24-px2r-5qmf

  3. Revision 1 · created ·

    Published from ghsa record GHSA-gc24-px2r-5qmf

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-25505

Advisory: Bambuddy Uses Hardcoded Secret Key + Many API Endpoints do not Require Authentication
IDs: CVE-2026-25505, GHSA-gc24-px2r-5qmf
Record: https://patchnext.com/advisories/cve-2026-25505 (revision 3, source checked 26 Oct 2026, 13:36 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: bambuddy 0.1.7. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI bambuddy: affected < 0.1.7; fixed in 0.1.7

## Suggested inspection (read-only)
- `python -m pip show bambuddy`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on bambuddy.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-gc24-px2r-5qmf (GitHub-reviewed advisory GHSA-gc24-px2r-5qmf lists affected ranges: PyPI bambuddy >=0 <0.1.7)
- Verified: https://osv.dev/vulnerability/GHSA-gc24-px2r-5qmf (OSV record GHSA-gc24-px2r-5qmf lists affected ranges: PyPI bambuddy >=0 <0.1.7 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…