Skip to content

← Actionable
High, CVSS 8.6

Craft CMS Vulnerable to potential authenticated Remote Code Execution via malicious attached Behavior

CVE-2026-25498GHSA-7jx7-3846-m7w7

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (craftcms/cms 5.8.22, 4.16.18), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist craftcms/cms

    Affected
    >= 5.0.0-RC1, <= 5.8.21>= 4.0.0-RC1, <= 4.16.17
    Fixed in
    5.8.22, 4.16.18

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.6 · CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-25498: 1.12% estimated exploitation activity in the next 30 days; percentile 66.13 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Relationship to Previously Patched Vulnerability This vulnerability is in addition to the RCE vulnerability patched in GHSA-255j-qw47-wjh5. That advisory addressed a similar RCE vulnerability that affected two specific routes: - /index.php?p=admin%2Factions%2Ffields%2Fapply-layout-element-settings - /index.php?p=admin%2Factions%2Ffields%2Frender-card-preview This one addresses some additional endpoints that were not covered in the https://github.com/craftcms/cms/security/advisories/GHSA-255j-qw47-wjh5. The patched vulnerability used a malicious AttributeTypecastBehavior with a wildcard event listener ("on ": "self::beforeSave") and construct() syntax to trigger RCE via the typecastBeforeSave callback. The fix was implemented in commits: - 6e608a1 - 27f5588 - ec43c49 This vulnerability follows the same attack pattern (behavior injection via "as <behavior" syntax) but affects a different code path (assembleLayoutFromPost() in Fields.php) that was not patched in those commits. The…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-7jx7-3846-m7w7

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-25498

Advisory: Craft CMS Vulnerable to potential authenticated Remote Code Execution via malicious attached Behavior
IDs: CVE-2026-25498, GHSA-7jx7-3846-m7w7
Record: https://patchnext.com/advisories/cve-2026-25498 (revision 1, source checked 26 Oct 2026, 14:38 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.6)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: craftcms/cms 5.8.22, 4.16.18. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist craftcms/cms: affected >= 5.0.0-RC1, <= 5.8.21; >= 4.0.0-RC1, <= 4.16.17; fixed in 5.8.22, 4.16.18

## Suggested inspection (read-only)
- Packagist craftcms/cms: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on craftcms/cms.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-7jx7-3846-m7w7 (GitHub-reviewed advisory GHSA-7jx7-3846-m7w7 lists affected ranges: Packagist craftcms/cms >=5.0.0-RC1 =4.0.0-RC1 <=4.16.17)

Commands are suggestions: review each one before running it.

Loading voting…