Craft Commerce has Stored XSS via Order Status Message with potential database exfiltration
CVE-2026-25483GHSA-8478-rmjg-mjj5
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (craftcms/commerce 5.5.2, 4.10.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist craftcms/commerce
- Affected
- >= 5.0.0, <= 5.5.1>= 4.0.0-RC1, <= 4.10.0
- Fixed in
- 4.10.1, 5.5.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-8478-rmjg-mjj5 lists affected ranges: Packagist craftcms/commerce >=5.0.0 =4.0.0-RC1 <=4.10.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.2 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:N/VI:N/VA:N/SC:H/SI:L/SA:N · score source
- EPSS
- CVE-2026-25483: 0.34% estimated exploitation activity in the next 30 days; percentile 27.74 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary A stored XSS vulnerability exists in Craft Commerce’s Order Status History Message. The message is rendered using the |md filter, which permits raw HTML, enabling malicious script execution. If a user has database backup utility permissions (which do not require an elevated session), an attacker can exfiltrate the entire database, including all user credentials, customer PII, order history, and 2FA recovery codes. Users are recommended to update to the patched 5.5.2 release to mitigate the issue. --- Proof of Concept Required Permissions - General - Access the control panel - Access Craft Commerce - Access to the database backup utility - Craft Commerce - Manage orders - Edit orders Attacker Server Setup To reproduce this attack, you need a server to receive the exfiltrated database. 1. Save the Python script as receiver.py on your attacker machine. 2. Run it: python3 receiver.py -- Change the port if needed. <details <summaryServer Python Script</summary </details Steps to…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-8478-rmjg-mjj5
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-25483 Advisory: Craft Commerce has Stored XSS via Order Status Message with potential database exfiltration IDs: CVE-2026-25483, GHSA-8478-rmjg-mjj5 Record: https://patchnext.com/advisories/cve-2026-25483 (revision 1, source checked 26 Oct 2026, 14:35 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.2) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: craftcms/commerce 5.5.2, 4.10.1. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist craftcms/commerce: affected >= 5.0.0, <= 5.5.1; >= 4.0.0-RC1, <= 4.10.0; fixed in 4.10.1, 5.5.2 ## Suggested inspection (read-only) - Packagist craftcms/commerce: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on craftcms/commerce. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-8478-rmjg-mjj5 (GitHub-reviewed advisory GHSA-8478-rmjg-mjj5 lists affected ranges: Packagist craftcms/commerce >=5.0.0 =4.0.0-RC1 <=4.10.0) Commands are suggestions: review each one before running it.
Loading voting…