Craft Commerce has Stored DOM XSS in Order Status Name (Reflects in "Recent Orders" Dashboard Widget)
CVE-2026-25482GHSA-frj9-9rwc-pw9j
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (craftcms/commerce 5.5.2, 4.10.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist craftcms/commerce
- Affected
- >= 5.0.0, <= 5.5.1>= 4.0.0-RC1, <= 4.10.0
- Fixed in
- 4.10.1, 5.5.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-frj9-9rwc-pw9j lists affected ranges: Packagist craftcms/commerce >=5.0.0 =4.0.0-RC1 <=4.10.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.2 · CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:P/VC:N/VI:N/VA:N/SC:H/SI:H/SA:N · score source
- EPSS
- CVE-2026-25482: 0.34% estimated exploitation activity in the next 30 days; percentile 28.18 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary A stored DOM XSS vulnerability exists in the "Recent Orders" dashboard widget. The Order Status Name is rendered via JavaScript string concatenation without proper escaping, allowing script execution when any admin visits the dashboard. Users are recommended to update to the patched 5.5.2 release to mitigate the issue. --- Proof of Concept Required Permissions - Admin access (to edit/create Order Statuses) Steps to Reproduce 1. Log in with an admin account 2. Navigate to Commerce → Settings → Order Statuses 3. Create new order status (e.g., "Pending") 4. Set the Name field to: 5. Save the order status 6. Go to Commerce Orders & make some orders with different statuses (e.g. "New" & "the malicious created status") 7. Go to the Dashboard (/admin/dashboard) & Add "Recent Orders" widget and pick the same 2 statuses for orders 8. Notice the XSS execution <img width="1491" height="568" alt="xss-execution-in-dashboard"…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-frj9-9rwc-pw9j
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-25482 Advisory: Craft Commerce has Stored DOM XSS in Order Status Name (Reflects in "Recent Orders" Dashboard Widget) IDs: CVE-2026-25482, GHSA-frj9-9rwc-pw9j Record: https://patchnext.com/advisories/cve-2026-25482 (revision 1, source checked 26 Oct 2026, 14:35 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.2) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: craftcms/commerce 5.5.2, 4.10.1. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist craftcms/commerce: affected >= 5.0.0, <= 5.5.1; >= 4.0.0-RC1, <= 4.10.0; fixed in 4.10.1, 5.5.2 ## Suggested inspection (read-only) - Packagist craftcms/commerce: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on craftcms/commerce. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-frj9-9rwc-pw9j (GitHub-reviewed advisory GHSA-frj9-9rwc-pw9j lists affected ranges: Packagist craftcms/commerce >=5.0.0 =4.0.0-RC1 <=4.10.0) Commands are suggestions: review each one before running it.
Loading voting…