Skip to content

← Actionable
Critical, CVSS 9.4amended

Langroid has WAF Bypass Leading to RCE in TableChatAgent

CVE-2026-25481GHSA-x34r-63hx-w57f

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (langroid 0.59.32), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI langroid

    Affected
    <= 0.59.31
    Fixed in
    0.59.32

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
9.4 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H · score source
EPSS
  • CVE-2026-25481: 0.73% estimated exploitation activity in the next 30 days; percentile 54.43 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Affected Scope langroid <= 0.59.31 Vulnerability Description CVE-2025-46724 fix bypass: TableChatAgent can call pandaseval tool to evaluate the expression. There is a WAF in langroid/utils/pandasutils.py introduced to block code injection CVE-2025-46724. However it can be bypassed due to literalok() returning False instead of raising UnsafeCommandError on invalid input, combined with unrestricted access to dangerous dunder attributes (init, globals, builtins). This allows chaining whitelisted DataFrame methods to leak the eval builtin and execute arbitrary code. Reproduction & PoC This payload is used to bypass the waf, when executed, the column name import('os').system('ls')#... will be passed to eval here is the PoC python df.addprefix("import('os').system('ls')#").T.groupby(by=df.init.globals['builtins']['eval']) after running this poc, command ls will be executed on the server <img width="2501" height="1256" alt="image"…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 4 · amended ·

    Amended from ghsa record GHSA-x34r-63hx-w57f

  2. Revision 3 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 2 · amended ·

    Amended from osv record GHSA-x34r-63hx-w57f

  4. Revision 1 · created ·

    Published from ghsa record GHSA-x34r-63hx-w57f

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-25481

Advisory: Langroid has WAF Bypass Leading to RCE in TableChatAgent
IDs: CVE-2026-25481, GHSA-x34r-63hx-w57f
Record: https://patchnext.com/advisories/cve-2026-25481 (revision 4, source checked 26 Oct 2026, 13:46 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: langroid 0.59.32. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI langroid: affected <= 0.59.31; fixed in 0.59.32

## Suggested inspection (read-only)
- `python -m pip show langroid`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on langroid.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-x34r-63hx-w57f (GitHub-reviewed advisory GHSA-x34r-63hx-w57f lists affected ranges: PyPI langroid >=0 <=0.59.31)
- Verified: https://osv.dev/vulnerability/GHSA-x34r-63hx-w57f (OSV record GHSA-x34r-63hx-w57f lists affected ranges: PyPI langroid >=0 <0.59.32 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…