Litestar's AllowedHosts has a validation bypass due to unescaped regex metacharacters in configured host patterns
CVE-2026-25479GHSA-93ph-p7v4-hwh4
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (litestar 2.20.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI litestar
- Affected
- >= 2.19.0, <= 2.19.0
- Fixed in
- 2.20.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-93ph-p7v4-hwh4 lists affected ranges: PyPI litestar >=2.19.0 <2.20.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-93ph-p7v4-hwh4 lists affected ranges: PyPI litestar >=2.19.0 <=2.19.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N
- EPSS
- CVE-2026-25479: 0.36% estimated exploitation activity in the next 30 days; percentile 29.64 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary AllowedHosts host validation can be bypassed because configured host patterns are turned into regular expressions without escaping regex metacharacters (notably .). A configured allowlist entry like example.com can match exampleXcom Details In litestar.middleware.allowedhosts, allowlist entries are compiled into regex patterns in a way that allows regex metacharacters to retain special meaning (e.g., . matches any character). This enables a bypass where an attacker supplies a host that matches the regex but is not the intended literal hostname. PoC Server (pocallowedhostsserver.py) uvicorn pocallowedhostsserver:app --host 127.0.0.1 --port 8001 Client (pocallowedhostsclient.py) Expected (vulnerable behavior): Host: evil.com → 400 invalid host Host: exampleXcom → 200 ok (bypass) Impact Type: security control bypass (host allowlist) Who is impacted: apps relying on AllowedHosts to prevent Host header attacks (cache poisoning, absolute URL construction abuse, password reset link…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-93ph-p7v4-hwh4
- Revision 1 · created ·
Published from osv record GHSA-93ph-p7v4-hwh4
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-25479 Advisory: Litestar's AllowedHosts has a validation bypass due to unescaped regex metacharacters in configured host patterns IDs: CVE-2026-25479, GHSA-93ph-p7v4-hwh4 Record: https://patchnext.com/advisories/cve-2026-25479 (revision 2, source checked 26 Oct 2026, 13:36 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: litestar 2.20.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI litestar: affected >= 2.19.0, <= 2.19.0; fixed in 2.20.0 ## Suggested inspection (read-only) - `python -m pip show litestar`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on litestar. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-93ph-p7v4-hwh4 (OSV record GHSA-93ph-p7v4-hwh4 lists affected ranges: PyPI litestar >=2.19.0 <2.20.0 (fixed)) - Verified: https://github.com/advisories/GHSA-93ph-p7v4-hwh4 (GitHub-reviewed advisory GHSA-93ph-p7v4-hwh4 lists affected ranges: PyPI litestar >=2.19.0 <=2.19.0) Commands are suggestions: review each one before running it.
Loading voting…