Litestar's CORS origin allowlist has a bypass due to unescaped regex metacharacters in allowed origins
CVE-2026-25478GHSA-2p2x-hpg8-cqp2
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (litestar 2.20.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI litestar
- Affected
- >= 2.19.0, <= 2.19.0
- Fixed in
- 2.20.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-2p2x-hpg8-cqp2 lists affected ranges: PyPI litestar >=2.19.0 <2.20.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-2p2x-hpg8-cqp2 lists affected ranges: PyPI litestar >=2.19.0 <=2.19.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.4 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:N/A:N
- EPSS
- CVE-2026-25478: 0.45% estimated exploitation activity in the next 30 days; percentile 38.82 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary CORS origin validation can be bypassed because the allowed-origins allowlist is compiled into a regex without escaping metacharacters (notably .). An allowed origin like https://good.example can match https://goodXexample, resulting in Access-Control-Allow-Origin being set for an untrusted origin Details CORSConfig.allowedoriginsregex is constructed using a regex built from configured allowlist values and used with fullmatch() for validation. Because metacharacters are not escaped, a malicious origin can match unexpectedly. The check relies on allowedoriginsregex.fullmatch(origin). PoC Server (poccorsserver.py) uvicorn poccorsserver:app --host 127.0.0.1 --port 8002 Client (poccorsclient.py) Expected (vulnerable behavior): Origin: https://evil.example → no ACAO Origin: https://goodXexample → ACAO: https://goodxexample/ (bypass) Impact Type: CORS policy bypass (cross-origin data exposure risk) Who is impacted: apps using CORS allowlists to restrict browser cross-origin reads.…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-2p2x-hpg8-cqp2
- Revision 1 · created ·
Published from osv record GHSA-2p2x-hpg8-cqp2
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-25478 Advisory: Litestar's CORS origin allowlist has a bypass due to unescaped regex metacharacters in allowed origins IDs: CVE-2026-25478, GHSA-2p2x-hpg8-cqp2 Record: https://patchnext.com/advisories/cve-2026-25478 (revision 2, source checked 26 Oct 2026, 13:36 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: litestar 2.20.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI litestar: affected >= 2.19.0, <= 2.19.0; fixed in 2.20.0 ## Suggested inspection (read-only) - `python -m pip show litestar`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on litestar. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-2p2x-hpg8-cqp2 (OSV record GHSA-2p2x-hpg8-cqp2 lists affected ranges: PyPI litestar >=2.19.0 <2.20.0 (fixed)) - Verified: https://github.com/advisories/GHSA-2p2x-hpg8-cqp2 (GitHub-reviewed advisory GHSA-2p2x-hpg8-cqp2 lists affected ranges: PyPI litestar >=2.19.0 <=2.19.0) Commands are suggestions: review each one before running it.
Loading voting…