Skip to content

← Actionable
High, CVSS 8.8amended

OpenClaw/Clawdbot has 1-Click RCE via Authentication Token Exfiltration From gatewayUrl

CVE-2026-25253GHSA-g8p2-7wf7-98mq

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (clawdbot 2026.1.29), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm clawdbot

    Affected
    <= 2026.1.28
    Fixed in
    2026.1.29

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
EPSS
  • CVE-2026-25253: 32.38% estimated exploitation activity in the next 30 days; percentile 98.33 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The Control UI trusts gatewayUrl from the query string without validation and auto-connects on load, sending the stored gateway token in the WebSocket connect payload. Clicking a crafted link or visiting a malicious site can send the token to an attacker-controlled server. The attacker can then connect to the victim's local gateway, modify config (sandbox, tool policies), and invoke privileged actions, achieving 1-click RCE. This vulnerability is exploitable even on instances configured to listen on loopback only, since the victim's browser initiates the outbound connection. Details The root cause is the lack of validation for gatewayUrl combined with auto‑connect behavior on page load. With the change users now need to confirm the new gateway URL in the UI. Impact This is a token exfiltration vulnerability that leads to full gateway compromise. It impacts any Moltbot deployment where a user has authenticated to the Control UI. The attacker gains operator-level access to the…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-g8p2-7wf7-98mq

  2. Revision 1 · created ·

    Published from osv record GHSA-g8p2-7wf7-98mq

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-25253

Advisory: OpenClaw/Clawdbot has 1-Click RCE via Authentication Token Exfiltration From gatewayUrl
IDs: CVE-2026-25253, GHSA-g8p2-7wf7-98mq
Record: https://patchnext.com/advisories/cve-2026-25253 (revision 2, source checked 26 Oct 2026, 12:41 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: clawdbot 2026.1.29. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm clawdbot: affected <= 2026.1.28; fixed in 2026.1.29

## Suggested inspection (read-only)
- `npm ls clawdbot --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on clawdbot.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-g8p2-7wf7-98mq (OSV record GHSA-g8p2-7wf7-98mq lists affected ranges: npm clawdbot >=0 <2026.1.29 (fixed))
- Verified: https://github.com/advisories/GHSA-g8p2-7wf7-98mq (GitHub-reviewed advisory GHSA-g8p2-7wf7-98mq lists affected ranges: npm clawdbot >=0 <=2026.1.28)

Commands are suggestions: review each one before running it.

Loading voting…