Skip to content

← Actionable
Medium, CVSS 5.0amended

SignalK Server has Path Traversal leading to information disclosure

CVE-2026-25228GHSA-vrhw-v2hw-jffx

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (signalk-server 2.20.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.0 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:N/A:N
EPSS
  • CVE-2026-25228: 0.43% estimated exploitation activity in the next 30 days; percentile 36.90 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary A Path Traversal vulnerability in SignalK Server's applicationData API allows authenticated users on Windows systems to read, write, and list arbitrary files and directories on the filesystem. The validateAppId() function blocks forward slashes (/) but not backslashes (\), which are treated as directory separators by path.join() on Windows. This enables attackers to escape the intended applicationData directory. Details Platform: Windows (Linux only allows traversal up a single directory) Authentication Required: Yes (ability to write depends on user's permission) The vulnerability exists in the validateAppId() function within the applicationData API handler. This function validates the appid parameter but only checks for forward slashes: Root Cause: - The validation only blocks / characters - On Windows, path.join() uses the platform's native path separator - Windows treats both / and \ as valid directory separators - Backslash-based traversal sequences like ..\..\.. pass…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-vrhw-v2hw-jffx

  2. Revision 1 · created ·

    Published from osv record GHSA-vrhw-v2hw-jffx

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-25228

Advisory: SignalK Server has Path Traversal leading to information disclosure
IDs: CVE-2026-25228, GHSA-vrhw-v2hw-jffx
Record: https://patchnext.com/advisories/cve-2026-25228 (revision 2, source checked 26 Oct 2026, 12:41 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.0)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: signalk-server 2.20.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm signalk-server: affected <= 2.20.2; fixed in 2.20.3

## Suggested inspection (read-only)
- `npm ls signalk-server --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on signalk-server.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-vrhw-v2hw-jffx (OSV record GHSA-vrhw-v2hw-jffx lists affected ranges: npm signalk-server >=0 <2.20.3 (fixed))
- Verified: https://github.com/advisories/GHSA-vrhw-v2hw-jffx (GitHub-reviewed advisory GHSA-vrhw-v2hw-jffx lists affected ranges: npm signalk-server >=0 <=2.20.2)

Commands are suggestions: review each one before running it.

Loading voting…