Fastify Vulnerable to DoS via Unbounded Memory Allocation in sendWebStream
CVE-2026-25224GHSA-mrq3-vjjr-p77c
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (fastify 5.7.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm fastify
- Affected
- <= 5.7.2
- Fixed in
- 5.7.3
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-mrq3-vjjr-p77c lists affected ranges: npm fastify >=0 <5.7.3 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-mrq3-vjjr-p77c lists affected ranges: npm fastify >=0 <=5.7.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 3.7 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:L
- EPSS
- CVE-2026-25224: 0.55% estimated exploitation activity in the next 30 days; percentile 45.83 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact A Denial of Service vulnerability in Fastify’s Web Streams response handling can allow a remote client to exhaust server memory. Applications that return a ReadableStream (or Response with a Web Stream body) via reply.send() are impacted. A slow or non-reading client can trigger unbounded buffering when backpressure is ignored, leading to process crashes or severe degradation. Patches The issue is fixed in Fastify 5.7.3. Users should upgrade to 5.7.3 or later. Workarounds Avoid sending Web Streams from Fastify responses (e.g., ReadableStream or Response bodies). Use Node.js streams (stream.Readable) or buffered payloads instead until the project can upgrade. References - https://hackerone.com/reports/3524779
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-mrq3-vjjr-p77c
- Revision 1 · created ·
Published from osv record GHSA-mrq3-vjjr-p77c
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-25224 Advisory: Fastify Vulnerable to DoS via Unbounded Memory Allocation in sendWebStream IDs: CVE-2026-25224, GHSA-mrq3-vjjr-p77c Record: https://patchnext.com/advisories/cve-2026-25224 (revision 2, source checked 26 Oct 2026, 12:42 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 3.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: fastify 5.7.3. A vendor fix does not mean a deployment is fixed. ## Affected components - npm fastify: affected <= 5.7.2; fixed in 5.7.3 ## Suggested inspection (read-only) - `npm ls fastify --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on fastify. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-mrq3-vjjr-p77c (OSV record GHSA-mrq3-vjjr-p77c lists affected ranges: npm fastify >=0 <5.7.3 (fixed)) - Verified: https://github.com/advisories/GHSA-mrq3-vjjr-p77c (GitHub-reviewed advisory GHSA-mrq3-vjjr-p77c lists affected ranges: npm fastify >=0 <=5.7.2) Commands are suggestions: review each one before running it.
Loading voting…