OpenClaw/Clawdbot has OS Command Injection via Project Root Path in sshNodeCommand
CVE-2026-25157GHSA-q284-4pvr-m585
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (clawdbot 2026.1.29), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm clawdbot
- Affected
- < 2026.1.29
- Fixed in
- 2026.1.29
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-q284-4pvr-m585 lists affected ranges: npm clawdbot >=0 <2026.1.29 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-q284-4pvr-m585 lists affected ranges: npm clawdbot >=0 <2026.1.29
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.7 · CVSS:3.1/AV:L/AC:H/PR:N/UI:R/S:C/C:H/I:H/A:H
- EPSS
- CVE-2026-25157: 1.05% estimated exploitation activity in the next 30 days; percentile 64.34 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Two related vulnerabilities existed in the macOS application's SSH remote connection handling (CommandResolver.swift): Details The sshNodeCommand function constructed a shell script without properly escaping the user-supplied project path in an error message. When the cd command failed, the unescaped path was interpolated directly into an echo statement, allowing arbitrary command execution on the remote SSH host. The parseSSHTarget function did not validate that SSH target strings could not begin with a dash. An attacker-supplied target like -oProxyCommand=... would be interpreted as an SSH configuration flag rather than a hostname, allowing arbitrary command execution on the local machine. Impact An attacker who can influence a user's remote connection settings (via social engineering or malicious configuration) could achieve arbitrary code execution on either the user's local machine or their configured remote SSH host, depending on which input vector is exploited. Affected…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-q284-4pvr-m585
- Revision 1 · created ·
Published from osv record GHSA-q284-4pvr-m585
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-25157 Advisory: OpenClaw/Clawdbot has OS Command Injection via Project Root Path in sshNodeCommand IDs: CVE-2026-25157, GHSA-q284-4pvr-m585 Record: https://patchnext.com/advisories/cve-2026-25157 (revision 2, source checked 26 Oct 2026, 12:42 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: clawdbot 2026.1.29. A vendor fix does not mean a deployment is fixed. ## Affected components - npm clawdbot: affected < 2026.1.29; fixed in 2026.1.29 ## Suggested inspection (read-only) - `npm ls clawdbot --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on clawdbot. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-q284-4pvr-m585 (OSV record GHSA-q284-4pvr-m585 lists affected ranges: npm clawdbot >=0 <2026.1.29 (fixed)) - Verified: https://github.com/advisories/GHSA-q284-4pvr-m585 (GitHub-reviewed advisory GHSA-q284-4pvr-m585 lists affected ranges: npm clawdbot >=0 <2026.1.29) Commands are suggestions: review each one before running it.
Loading voting…