Skip to content

← Actionable
High, CVSS 8.1amended

Rucio WebUI has a Reflected Cross-site Scripting Vulnerability

CVE-2026-25136GHSA-h79m-5jjm-jm4q

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (rucio-webui 39.3.1, 38.5.4, 35.8.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI rucio-webui

    Affected
    < 35.8.3>= 36.0.0rc1, < 38.5.4>= 39.0.0rc1, < 39.3.1
    Fixed in
    39.3.1, 38.5.4, 35.8.3

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N
EPSS
  • CVE-2026-25136: 0.31% estimated exploitation activity in the next 30 days; percentile 23.92 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary A reflected Cross-site Scripting vulnerability was located in the rendering of the ExceptionMessage of the WebUI 500 error which could allow attackers to steal login session tokens of users who navigate to a specially crafted URL. Details The WebUI error message renders ExceptionMessage (which can contain user-controlled input) as unencoded HTML. Server code that produces the message is in common.py - specifically errorheaders - errorresponse - generatehttperrorflask, which places ExceptionMessage into both response headers and the JSON body. The WebUI client then injects that text into the DOM using unsafe methods (examples in lib/rucio/web/ui/static/.js such as rule.js, requestrule.js, listrules.js) with jQuery.html(...) or equivalent, enabling reflected XSS when an attacker-controlled value is included in an error message (e.g. account, attribute, scope). PoC 1) Reflected XSS via account parameter (browse or load URL in WebUI context): Server response (excerpt): XSS…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-h79m-5jjm-jm4q

  2. Revision 1 · created ·

    Published from osv record GHSA-h79m-5jjm-jm4q

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-25136

Advisory: Rucio WebUI has a Reflected Cross-site Scripting Vulnerability
IDs: CVE-2026-25136, GHSA-h79m-5jjm-jm4q
Record: https://patchnext.com/advisories/cve-2026-25136 (revision 2, source checked 26 Oct 2026, 13:36 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: rucio-webui 39.3.1, 38.5.4, 35.8.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI rucio-webui: affected < 35.8.3; >= 36.0.0rc1, < 38.5.4; >= 39.0.0rc1, < 39.3.1; fixed in 39.3.1, 38.5.4, 35.8.3

## Suggested inspection (read-only)
- `python -m pip show rucio-webui`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on rucio-webui.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-h79m-5jjm-jm4q (OSV record GHSA-h79m-5jjm-jm4q lists affected ranges: PyPI rucio-webui >=0 =36.0.0rc1 =39.0.0rc1 <39.3.1 (fixed))
- Verified: https://github.com/advisories/GHSA-h79m-5jjm-jm4q (GitHub-reviewed advisory GHSA-h79m-5jjm-jm4q lists affected ranges: PyPI rucio-webui >=0 =36.0.0rc1 =39.0.0rc1 <39.3.1)

Commands are suggestions: review each one before running it.

Loading voting…