fast-xml-parser has RangeError DoS Numeric Entities Bug
CVE-2026-25128GHSA-37qj-frw5-hhjh
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (fast-xml-parser 5.3.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm fast-xml-parser
- Affected
- >= 5.0.9, <= 5.3.3
- Fixed in
- 5.3.4
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-37qj-frw5-hhjh lists affected ranges: npm fast-xml-parser >=5.0.9 <5.3.4 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-37qj-frw5-hhjh lists affected ranges: npm fast-xml-parser >=5.0.9 <=5.3.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2026-25128: 0.61% estimated exploitation activity in the next 30 days; percentile 49.37 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary A RangeError vulnerability exists in the numeric entity processing of fast-xml-parser when parsing XML with out-of-range entity code points (e.g., � or �). This causes the parser to throw an uncaught exception, crashing any application that processes untrusted XML input. Details The vulnerability exists in /src/xmlparser/OrderedObjParser.js at lines 44-45: The String.fromCodePoint() method throws a RangeError when the code point exceeds the valid Unicode range (0 to 0x10FFFF / 1114111). The regex patterns can capture values far exceeding this: - [0-9]{1,7} matches up to 9,999,999 - [0-9a-fA-F]{1,6} matches up to 0xFFFFFF (16,777,215) The entity replacement in replaceEntitiesValue() (line 452) has no try-catch: This causes the RangeError to propagate uncaught, crashing the parser and any application using it. PoC Setup Create a directory with these files: package.json server.js Run Result Server crashes with: Alternative Payloads Impact Denial of Service…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-37qj-frw5-hhjh
- Revision 1 · created ·
Published from osv record GHSA-37qj-frw5-hhjh
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-25128 Advisory: fast-xml-parser has RangeError DoS Numeric Entities Bug IDs: CVE-2026-25128, GHSA-37qj-frw5-hhjh Record: https://patchnext.com/advisories/cve-2026-25128 (revision 2, source checked 26 Oct 2026, 12:42 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: fast-xml-parser 5.3.4. A vendor fix does not mean a deployment is fixed. ## Affected components - npm fast-xml-parser: affected >= 5.0.9, <= 5.3.3; fixed in 5.3.4 ## Suggested inspection (read-only) - `npm ls fast-xml-parser --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on fast-xml-parser. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-37qj-frw5-hhjh (OSV record GHSA-37qj-frw5-hhjh lists affected ranges: npm fast-xml-parser >=5.0.9 <5.3.4 (fixed)) - Verified: https://github.com/advisories/GHSA-37qj-frw5-hhjh (GitHub-reviewed advisory GHSA-37qj-frw5-hhjh lists affected ranges: npm fast-xml-parser >=5.0.9 <=5.3.3) Commands are suggestions: review each one before running it.
Loading voting…