Skip to content

← Actionable
Medium, CVSS 4.9

October Rain has Environment Variable Exfiltration via INI Parser Interpolation

CVE-2026-25125GHSA-g6v3-wv4j-x9hg

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (october/rain 4.1.10, 3.7.14), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist october/rain

    Affected
    >= 4.0.0, <= 4.1.9<= 3.7.13
    Fixed in
    4.1.10, 3.7.14

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.9 · CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:N/A:N
EPSS
  • CVE-2026-25125: 0.33% estimated exploitation activity in the next 30 days; percentile 25.75 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

A server-side information disclosure vulnerability was identified in the INI settings parser. PHP's parseinistring() function supports ${} syntax for environment variable interpolation. Attackers with Editor access could inject ${APPKEY}, ${DBPASSWORD}, or similar patterns into CMS page settings fields, causing sensitive environment variables to be resolved and stored in the template. These values were then returned to the attacker when the page was reopened. Impact - Exfiltration of sensitive environment variables (APPKEY, DB credentials, AWS keys, etc.) - Could enable further attacks: database access, cookie forgery, AWS resource access - Requires authenticated backend access with Editor permissions - Only relevant when cms.safemode is enabled (otherwise direct PHP injection is already possible) Patches The vulnerability has been patched in v3.7.14 and v4.1.10. All users are encouraged to upgrade to the latest patched version. Workarounds If upgrading immediately is not possible: -…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-g6v3-wv4j-x9hg

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-25125

Advisory: October Rain has Environment Variable Exfiltration via INI Parser Interpolation
IDs: CVE-2026-25125, GHSA-g6v3-wv4j-x9hg
Record: https://patchnext.com/advisories/cve-2026-25125 (revision 1, source checked 26 Oct 2026, 14:49 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: october/rain 4.1.10, 3.7.14. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist october/rain: affected >= 4.0.0, <= 4.1.9; <= 3.7.13; fixed in 4.1.10, 3.7.14

## Suggested inspection (read-only)
- Packagist october/rain: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on october/rain.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-g6v3-wv4j-x9hg (GitHub-reviewed advisory GHSA-g6v3-wv4j-x9hg lists affected ranges: Packagist october/rain >=4.0.0 =0 <=3.7.13)

Commands are suggestions: review each one before running it.

Loading voting…