n8n has a Python sandbox escape
CVE-2026-25115GHSA-8398-gmmx-564h
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (n8n 2.4.8), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm n8n
- Affected
- < 2.4.8
- Fixed in
- 2.4.8
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-8398-gmmx-564h lists affected ranges: npm n8n >=0 <2.4.8
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-8398-gmmx-564h lists affected ranges: npm n8n >=0 <2.4.8 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 9.4 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H · score source
- EPSS
- CVE-2026-25115: 0.58% estimated exploitation activity in the next 30 days; percentile 47.58 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact A vulnerability in the Python Code node allows authenticated users to break out of the Python sandbox environment and execute code outside the intended security boundary. Only authenticated users are able to execute code through Task Runners. This issue affected any deployment in which the following conditions were met: - Task Runners were enabled using N8NRUNNERSENABLED=true (default: false) - Python was enabled N8NPYTHONENABLED=true - Code Node was enabled (default: true) In case the N8NRUNNERSMODE is set to external (default: internal) the sandbox escape is limited to the sidecar container with lower risk for lateral movement. In that case a lower high severity is more appropriate. Patches This vulnerability is fixed in version 2.4.8 and later. Workarounds If an immediate upgrade cannot be applied, the following hardening steps are recommended: - Disable the Code Node by adding n8n-nodes-base.code to the NODESEXCLUDE environment variable - Prefer external mode for…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 4 · amended ·
Amended from ghsa record GHSA-8398-gmmx-564h
- Revision 3 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 2 · amended ·
Amended from osv record GHSA-8398-gmmx-564h
- Revision 1 · created ·
Published from ghsa record GHSA-8398-gmmx-564h
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-25115 Advisory: n8n has a Python sandbox escape IDs: CVE-2026-25115, GHSA-8398-gmmx-564h Record: https://patchnext.com/advisories/cve-2026-25115 (revision 4, source checked 26 Oct 2026, 12:46 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: n8n 2.4.8. A vendor fix does not mean a deployment is fixed. ## Affected components - npm n8n: affected < 2.4.8; fixed in 2.4.8 ## Suggested inspection (read-only) - `npm ls n8n --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on n8n. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-8398-gmmx-564h (GitHub-reviewed advisory GHSA-8398-gmmx-564h lists affected ranges: npm n8n >=0 <2.4.8) - Verified: https://osv.dev/vulnerability/GHSA-8398-gmmx-564h (OSV record GHSA-8398-gmmx-564h lists affected ranges: npm n8n >=0 <2.4.8 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…