Skip to content

← Actionable
High, CVSS 7.0amended

Apache Arrow: Potential use-after-free when reading IPC file with pre-buffering

CVE-2026-25087GHSA-rgxp-2hwp-jwgg

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (pyarrow 23.0.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI pyarrow

    Affected
    >= 15.0.0, < 23.0.1
    Fixed in
    23.0.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.0 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:H
EPSS
  • CVE-2026-25087: 0.90% estimated exploitation activity in the next 30 days; percentile 59.81 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Use After Free vulnerability in Apache Arrow C++. This issue affects Apache Arrow C++ from 15.0.0 through 23.0.0. It can be triggered when reading an Arrow IPC file (but not an IPC stream) with pre-buffering enabled, if the IPC file contains data with variadic buffers (such as Binary View and String View data). Depending on the number of variadic buffers in a record batch column and on the temporal sequence of multi-threaded IO, a write to a dangling pointer could occur. The value (a std::sharedptr<Buffer object) that is written to the dangling pointer is not under direct control of the attacker. Pre-buffering is disabled by default but can be enabled using a specific C++ API call (RecordBatchFileReader::PreBufferMetadata). The functionality is not exposed in language bindings (Python, Ruby, C GLib), so these bindings are not vulnerable. The most likely consequence of this issue would be random crashes or memory corruption when reading specific kinds of IPC files. If the application…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-rgxp-2hwp-jwgg

  2. Revision 1 · created ·

    Published from osv record GHSA-rgxp-2hwp-jwgg

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-25087

Advisory: Apache Arrow: Potential use-after-free when reading IPC file with pre-buffering
IDs: CVE-2026-25087, GHSA-rgxp-2hwp-jwgg
Record: https://patchnext.com/advisories/cve-2026-25087 (revision 2, source checked 26 Oct 2026, 13:42 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.0)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: pyarrow 23.0.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI pyarrow: affected >= 15.0.0, < 23.0.1; fixed in 23.0.1

## Suggested inspection (read-only)
- `python -m pip show pyarrow`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on pyarrow.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-rgxp-2hwp-jwgg (OSV record GHSA-rgxp-2hwp-jwgg lists affected ranges: PyPI pyarrow >=15.0.0 <23.0.1 (fixed))
- Verified: https://github.com/advisories/GHSA-rgxp-2hwp-jwgg (GitHub-reviewed advisory GHSA-rgxp-2hwp-jwgg lists affected ranges: PyPI pyarrow >=15.0.0 <23.0.1)

Commands are suggestions: review each one before running it.

Loading voting…