Skip to content

← Actionable
High, CVSS 8.1

OpenList has Insecure TLS Default Configuration

CVE-2026-25060GHSA-wf93-3ghh-h389

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/OpenListTeam/OpenList/v4 4.1.10), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.1 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2026-25060: 0.25% estimated exploitation activity in the next 30 days; percentile 16.38 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The application disables TLS certificate verification by default for all outgoing storage driver communications, making the system vulnerable to Man-in-the-Middle (MitM) attacks. This enables the complete decryption, theft, and manipulation of all data transmitted during storage operations, severely compromising the confidentiality and integrity of user data. Details Certificate verification is disabled by default for all storage driver communications. The TlsInsecureSkipVerify setting is default to true in the DefaultConfig() function in internal/conf/config.go. ~~~ func DefaultConfig() Config { // ... TlsInsecureSkipVerify: true, // ... } ~~~ This vulnerability enables Man-in-the-Middle (MitM) attacks by disabling TLS certificate verification, allowing attackers to intercept and manipulate all storage communications. Attackers can exploit this through network-level attacks like ARP spoofing, rogue Wi-Fi access points, or compromised internal network equipment to redirect…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-wf93-3ghh-h389

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-25060

Advisory: OpenList has Insecure TLS Default Configuration
IDs: CVE-2026-25060, GHSA-wf93-3ghh-h389
Record: https://patchnext.com/advisories/cve-2026-25060 (revision 1, source checked 26 Oct 2026, 15:14 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/OpenListTeam/OpenList/v4 4.1.10. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/OpenListTeam/OpenList/v4: affected < 4.1.10; fixed in 4.1.10

## Suggested inspection (read-only)
- Go github.com/OpenListTeam/OpenList/v4: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/OpenListTeam/OpenList/v4.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-wf93-3ghh-h389 (GitHub-reviewed advisory GHSA-wf93-3ghh-h389 lists affected ranges: Go github.com/OpenListTeam/OpenList/v4 >=0 <4.1.10)

Commands are suggestions: review each one before running it.

Loading voting…