Skip to content

← Actionable
High, CVSS 7.1amended

n8n Vulnerable to Arbitrary File Write on Remote Systems via SSH Node

CVE-2026-25055GHSA-m82q-59gv-mcr9

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (n8n 2.4.0, 1.123.12), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm n8n

    Affected
    >= 2.0.0, < 2.4.0< 1.123.12
    Fixed in
    2.4.0, 1.123.12

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
7.1 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:N/SC:H/SI:H/SA:H · score source
EPSS
  • CVE-2026-25055: 1.86% estimated exploitation activity in the next 30 days; percentile 79.27 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact When workflows process uploaded files and transfer them to remote servers via the SSH node without validating their metadata the vulnerability can lead to files being written to unintended locations on those remote systems potentially leading to remote code execution on those systems. As a prerequisites an unauthenticated attacker needs knowledge of such workflows existing and the endpoints for file uploads need to be unauthenticated. Patches The issue has been fixed in n8n version 2.4.0 and 1.123.12. Users should upgrade to this version or later to remediate the vulnerability. Workarounds If upgrading is not immediately possible, administrators should consider the following temporary mitigations: - Disable or restrict access to workflows that accept file uploads via webhooks and transfer them via SSH. - Enable webhook authentication on all endpoints that handle file uploads. - Review usage of SSH credentials and consider rotating SSH credentials if in doubt. These workarounds…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-m82q-59gv-mcr9

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-m82q-59gv-mcr9

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-25055

Advisory: n8n Vulnerable to Arbitrary File Write on Remote Systems via SSH Node
IDs: CVE-2026-25055, GHSA-m82q-59gv-mcr9
Record: https://patchnext.com/advisories/cve-2026-25055 (revision 3, source checked 26 Oct 2026, 12:42 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: n8n 2.4.0, 1.123.12. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm n8n: affected >= 2.0.0, < 2.4.0; < 1.123.12; fixed in 2.4.0, 1.123.12

## Suggested inspection (read-only)
- `npm ls n8n --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on n8n.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-m82q-59gv-mcr9 (OSV record GHSA-m82q-59gv-mcr9 lists affected ranges: npm n8n >=2.0.0 =0 <1.123.12 (fixed))
- Verified: https://github.com/advisories/GHSA-m82q-59gv-mcr9 (GitHub-reviewed advisory GHSA-m82q-59gv-mcr9 lists affected ranges: npm n8n >=2.0.0 =0 <1.123.12)

Commands are suggestions: review each one before running it.

Loading voting…