n8n's Improper File Access Controls Allow Arbitrary File Read by Authenticated Users
CVE-2026-25052GHSA-gfvg-qv54-r4pc
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (n8n 2.5.0, 1.123.18), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm n8n
- Affected
- >= 2.0.0, < 2.5.0< 1.123.18
- Fixed in
- 1.123.18, 2.5.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-gfvg-qv54-r4pc lists affected ranges: npm n8n >=2.0.0 =0 <1.123.18
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-gfvg-qv54-r4pc lists affected ranges: npm n8n >=2.0.0 =0 <1.123.18 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 9.4 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H · score source
- EPSS
- CVE-2026-25052: 0.33% estimated exploitation activity in the next 30 days; percentile 26.09 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact A vulnerability in the file access controls allows authenticated users with permission to create or modify workflows to read sensitive files from the n8n host system. This can be exploited to obtain critical configuration data and user credentials, leading to complete account takeover of any user on the instance. Patches The issue has been fixed in n8n version 1.123.18 and 2.5.0. Users should upgrade to this version or later to remediate the vulnerability. Workarounds If upgrading is not immediately possible, administrators should consider the following temporary mitigations: - Limit workflow creation and editing permissions to fully trusted users only. - Restrict access to nodes that interact with the file system, particularly the "Read/Write Files from Disk" and "Git" nodes. These workarounds do not fully remediate the risk and should only be used as short-term mitigation measures. Resources - n8n Documentation — Blocking nodes — how to globally disable specific nodes ---…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 4 · amended ·
Amended from ghsa record GHSA-gfvg-qv54-r4pc
- Revision 3 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 2 · amended ·
Amended from osv record GHSA-gfvg-qv54-r4pc
- Revision 1 · created ·
Published from ghsa record GHSA-gfvg-qv54-r4pc
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-25052 Advisory: n8n's Improper File Access Controls Allow Arbitrary File Read by Authenticated Users IDs: CVE-2026-25052, GHSA-gfvg-qv54-r4pc Record: https://patchnext.com/advisories/cve-2026-25052 (revision 4, source checked 26 Oct 2026, 12:42 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: n8n 2.5.0, 1.123.18. A vendor fix does not mean a deployment is fixed. ## Affected components - npm n8n: affected >= 2.0.0, < 2.5.0; < 1.123.18; fixed in 1.123.18, 2.5.0 ## Suggested inspection (read-only) - `npm ls n8n --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on n8n. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-gfvg-qv54-r4pc (GitHub-reviewed advisory GHSA-gfvg-qv54-r4pc lists affected ranges: npm n8n >=2.0.0 =0 <1.123.18) - Verified: https://osv.dev/vulnerability/GHSA-gfvg-qv54-r4pc (OSV record GHSA-gfvg-qv54-r4pc lists affected ranges: npm n8n >=2.0.0 =0 <1.123.18 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…