Vendure vulnerable to timing attack that enables user enumeration in NativeAuthenticationStrategy
CVE-2026-25050GHSA-6f65-4fv2-wwch
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@vendure/core 3.5.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm @vendure/core
- Affected
- < 3.5.3
- Fixed in
- 3.5.3
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-6f65-4fv2-wwch lists affected ranges: npm @vendure/core >=0 <3.5.3 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-6f65-4fv2-wwch lists affected ranges: npm @vendure/core >=0 <3.5.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 2.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N/E:U · score source
- EPSS
- CVE-2026-25050: 0.40% estimated exploitation activity in the next 30 days; percentile 34.26 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary The NativeAuthenticationStrategy.authenticate() method is vulnerable to a timing attack that allows attackers to enumerate valid usernames (email addresses). Details In packages/core/src/config/auth/native-authentication-strategy.ts, the authenticate method returns immediately if a user is not found: The significant timing difference (~200-400ms for bcrypt vs ~1-5ms for DB miss) allows attackers to reliably distinguish between existing and non-existing accounts. Impact - Attackers can enumerate valid user accounts - Enables targeted brute-force or phishing attacks - Information disclosure (account existence) Recommended Fix Perform a dummy bcrypt check when user is not found to ensure consistent response times.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-6f65-4fv2-wwch
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-6f65-4fv2-wwch
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-25050 Advisory: Vendure vulnerable to timing attack that enables user enumeration in NativeAuthenticationStrategy IDs: CVE-2026-25050, GHSA-6f65-4fv2-wwch Record: https://patchnext.com/advisories/cve-2026-25050 (revision 3, source checked 26 Oct 2026, 12:41 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 2.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @vendure/core 3.5.3. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @vendure/core: affected < 3.5.3; fixed in 3.5.3 ## Suggested inspection (read-only) - `npm ls @vendure/core --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @vendure/core. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-6f65-4fv2-wwch (OSV record GHSA-6f65-4fv2-wwch lists affected ranges: npm @vendure/core >=0 <3.5.3 (fixed)) - Verified: https://github.com/advisories/GHSA-6f65-4fv2-wwch (GitHub-reviewed advisory GHSA-6f65-4fv2-wwch lists affected ranges: npm @vendure/core >=0 <3.5.3) Commands are suggestions: review each one before running it.
Loading voting…