Skip to content

← Actionable
Critical, CVSS 9.4amended

deepHas vulnerable to Prototype Pollution via constructor.prototype

CVE-2026-25047GHSA-2733-6c58-pf27

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (deephas 1.0.8), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm deephas

    Affected
    < 1.0.8
    Fixed in
    1.0.8

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
9.4 · CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H · score source
EPSS
  • CVE-2026-25047: 0.80% estimated exploitation activity in the next 30 days; percentile 56.52 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary A prototype pollution vulnerability exists in version 1.0.7 of the deephas npm package that allows an attacker to modify global object behavior. This issue was fixed in version 1.0.8. Details The vulnerability resides in the add() function and indexer() function implemented within deepHas.js. Although version 1.0.7 attempts to prevent prototype pollution by checking property ownership (e.g., using Object.hasOwnProperty) and by checking against forbidden string usage (using String.prototype.indexOf), this check can be bypassed as shown in the PoC By doing so, an attacker can inject properties into Object.prototype through a payload such as constructor.prototype.polluted or proto.polluted resulting in prototype pollution. This issue affects all JavaScript runtimes that rely on npm packages (including Node.js, Deno, and Bun) and is independent of the operating system. PoC Steps to reproduce 1. Install version 1.0.7 of deephas using npm install 2. Run one of the following code…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 4 · amended ·

    Amended from ghsa record GHSA-2733-6c58-pf27

  2. Revision 3 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 2 · amended ·

    Amended from osv record GHSA-2733-6c58-pf27

  4. Revision 1 · created ·

    Published from ghsa record GHSA-2733-6c58-pf27

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-25047

Advisory: deepHas vulnerable to Prototype Pollution via constructor.prototype
IDs: CVE-2026-25047, GHSA-2733-6c58-pf27
Record: https://patchnext.com/advisories/cve-2026-25047 (revision 4, source checked 26 Oct 2026, 12:42 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: deephas 1.0.8. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm deephas: affected < 1.0.8; fixed in 1.0.8

## Suggested inspection (read-only)
- `npm ls deephas --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on deephas.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-2733-6c58-pf27 (GitHub-reviewed advisory GHSA-2733-6c58-pf27 lists affected ranges: npm deephas >=0 <1.0.8)
- Verified: https://osv.dev/vulnerability/GHSA-2733-6c58-pf27 (OSV record GHSA-2733-6c58-pf27 lists affected ranges: npm deephas >=0 <1.0.8 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…