@budibase/server: Command Injection in PostgreSQL Dump Command
CVE-2026-25041GHSA-726g-59wr-cj4c
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@budibase/server 3.23.32), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm @budibase/server
- Affected
- < 3.23.32
- Fixed in
- 3.23.32
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-726g-59wr-cj4c lists affected ranges: npm @budibase/server >=0 <3.23.32 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-726g-59wr-cj4c lists affected ranges: npm @budibase/server >=0 <3.23.32
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.6 · CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-25041: 0.50% estimated exploitation activity in the next 30 days; percentile 42.84 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Location: packages/server/src/integrations/postgres.ts:529-531 Description The PostgreSQL integration constructs shell commands using user-controlled configuration values (database name, host, password, etc.) without proper sanitization. The password and other connection parameters are directly interpolated into a shell command. Code Reference Attack Vector An attacker who can control database configuration values (e.g., through compromised credentials or configuration injection) can inject shell commands. For example: - Password: password"; malicious-command; echo " - Database name: db"; rm -rf /; echo " Impact - Remote code execution - System compromise - Data exfiltration Recommendation 1. Use environment variables for sensitive values instead of command-line arguments 2. Validate and sanitize all configuration values 3. Use proper escaping for shell arguments 4. Consider using a PostgreSQL library's native dump functionality instead of shell commands Example Fix
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-726g-59wr-cj4c
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-726g-59wr-cj4c
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-25041 Advisory: @budibase/server: Command Injection in PostgreSQL Dump Command IDs: CVE-2026-25041, GHSA-726g-59wr-cj4c Record: https://patchnext.com/advisories/cve-2026-25041 (revision 3, source checked 26 Oct 2026, 12:43 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.6) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @budibase/server 3.23.32. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @budibase/server: affected < 3.23.32; fixed in 3.23.32 ## Suggested inspection (read-only) - `npm ls @budibase/server --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @budibase/server. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-726g-59wr-cj4c (OSV record GHSA-726g-59wr-cj4c lists affected ranges: npm @budibase/server >=0 <3.23.32 (fixed)) - Verified: https://github.com/advisories/GHSA-726g-59wr-cj4c (GitHub-reviewed advisory GHSA-726g-59wr-cj4c lists affected ranges: npm @budibase/server >=0 <3.23.32) Commands are suggestions: review each one before running it.
Loading voting…