Skip to content

← Actionable
Medium, CVSS 5.9amended

vlt Mishandles Path Sanitization for tar

CVE-2026-24909GHSA-gf2c-jwcj-x929

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@vltpkg/tar 1.0.0-rc.10), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm @vltpkg/tar

    Affected
    < 1.0.0-rc.10
    Fixed in
    1.0.0-rc.10

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.9 · CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:C/C:N/I:H/A:N
EPSS
  • CVE-2026-24909: 0.19% estimated exploitation activity in the next 30 days; percentile 9.31 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

vlt before 1.0.0-rc.10 mishandles path sanitization for tar, leading to path traversal during extraction.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-gf2c-jwcj-x929

  2. Revision 1 · created ·

    Published from osv record GHSA-gf2c-jwcj-x929

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-24909

Advisory: vlt Mishandles Path Sanitization for tar
IDs: CVE-2026-24909, GHSA-gf2c-jwcj-x929
Record: https://patchnext.com/advisories/cve-2026-24909 (revision 2, source checked 26 Oct 2026, 12:41 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @vltpkg/tar 1.0.0-rc.10. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @vltpkg/tar: affected < 1.0.0-rc.10; fixed in 1.0.0-rc.10

## Suggested inspection (read-only)
- `npm ls @vltpkg/tar --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @vltpkg/tar.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-gf2c-jwcj-x929 (OSV record GHSA-gf2c-jwcj-x929 lists affected ranges: npm @vltpkg/tar >=0 <1.0.0-rc.10 (fixed))
- Verified: https://github.com/advisories/GHSA-gf2c-jwcj-x929 (GitHub-reviewed advisory GHSA-gf2c-jwcj-x929 lists affected ranges: npm @vltpkg/tar >=0 <1.0.0-rc.10)

Commands are suggestions: review each one before running it.

Loading voting…