October CMS has Stored XSS in Event Log Mail Preview
CVE-2026-24907GHSA-j4j5-9x6g-rgxc
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (october/system 4.1.10, 3.7.14), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist october/system
- Affected
- >= 4.0.0, <= 4.1.9<= 3.7.13
- Fixed in
- 4.1.10, 3.7.14
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-j4j5-9x6g-rgxc lists affected ranges: Packagist october/system >=4.0.0 =0 <=3.7.13
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 5.1 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N · score source
- EPSS
- CVE-2026-24907: 0.20% estimated exploitation activity in the next 30 days; percentile 9.70 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A stored cross-site scripting (XSS) vulnerability was identified in the Event Log mail preview feature. When viewing logged mail messages, HTML content was rendered in an iframe without proper sandboxing, allowing JavaScript execution in the viewer's browser context. Impact - Stored XSS via mail template content rendered in Event Log - Could allow privilege escalation if a superuser views a malicious log entry - Requires authenticated backend access with mail template editing permissions - Requires a superuser to view the specific Event Log entry to trigger Patches The vulnerability has been patched in v3.7.14 and v4.1.10. All users are encouraged to upgrade to the latest patched version. Workarounds If upgrading immediately is not possible: - Restrict mail template editing permissions to fully trusted administrators only - Restrict Event Log viewing permissions to minimize exposure References - Reported by Chris Alupului
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-j4j5-9x6g-rgxc
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-24907 Advisory: October CMS has Stored XSS in Event Log Mail Preview IDs: CVE-2026-24907, GHSA-j4j5-9x6g-rgxc Record: https://patchnext.com/advisories/cve-2026-24907 (revision 1, source checked 26 Oct 2026, 14:39 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: october/system 4.1.10, 3.7.14. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist october/system: affected >= 4.0.0, <= 4.1.9; <= 3.7.13; fixed in 4.1.10, 3.7.14 ## Suggested inspection (read-only) - Packagist october/system: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on october/system. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-j4j5-9x6g-rgxc (GitHub-reviewed advisory GHSA-j4j5-9x6g-rgxc lists affected ranges: Packagist october/system >=4.0.0 =0 <=3.7.13) Commands are suggestions: review each one before running it.
Loading voting…