soroban-sdk has overflow in Bytes::slice, Vec::slice, GenRange::gen_range for u64
CVE-2026-24889GHSA-96xm-fv9w-pf3f
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (soroban-sdk 25.0.2, 23.5.1, 22.0.9), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
crates.io soroban-sdk
- Affected
- >= 25.0.0, < 25.0.2>= 23.0.0, < 23.5.1< 22.0.9
- Fixed in
- 23.5.1, 25.0.2, 22.0.9
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-96xm-fv9w-pf3f lists affected ranges: crates.io soroban-sdk >=25.0.0 =23.0.0 =0 <22.0.9
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
- EPSS
- CVE-2026-24889: 0.38% estimated exploitation activity in the next 30 days; percentile 32.51 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Arithmetic overflow can be triggered in the Bytes::slice, Vec::slice, and Prng::genrange (for u64) methods in the soroban-sdk in versions prior to and including 25.0.1. Contracts that pass user-controlled or computed range bounds to Bytes::slice, Vec::slice, or Prng::genrange may silently operate on incorrect data ranges or generate random numbers from an unintended range, potentially resulting in corrupted contract state. Note that the best practice when using the soroban-sdk and building Soroban contracts is to always enable overflow-checks = true. The stellar contract init tool that prepares the boiler plate for a Soroban contract, as well as all examples and docs, encourage the use of configuring overflow-checks = true on release profiles so that these arithmetic operations fail rather than silently wrap. Contracts are only impacted if they use overflow-checks = false either explicitly or implicitly. It is anticipated the majority of contracts could not be impacted because…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-96xm-fv9w-pf3f
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-24889 Advisory: soroban-sdk has overflow in Bytes::slice, Vec::slice, GenRange::gen_range for u64 IDs: CVE-2026-24889, GHSA-96xm-fv9w-pf3f Record: https://patchnext.com/advisories/cve-2026-24889 (revision 1, source checked 26 Oct 2026, 15:39 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: soroban-sdk 25.0.2, 23.5.1, 22.0.9. A vendor fix does not mean a deployment is fixed. ## Affected components - crates.io soroban-sdk: affected >= 25.0.0, < 25.0.2; >= 23.0.0, < 23.5.1; < 22.0.9; fixed in 23.5.1, 25.0.2, 22.0.9 ## Suggested inspection (read-only) - crates.io soroban-sdk: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on soroban-sdk. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-96xm-fv9w-pf3f (GitHub-reviewed advisory GHSA-96xm-fv9w-pf3f lists affected ranges: crates.io soroban-sdk >=25.0.0 =23.0.0 =0 <22.0.9) Commands are suggestions: review each one before running it.
Loading voting…