Compressing Vulnerable to Arbitrary File Write via Symlink Extraction
CVE-2026-24884GHSA-cc8f-xg8v-72m3
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (compressing 2.0.1, 1.10.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm compressing
- Affected
- >= 2.0.0, <= 2.0.0<= 1.10.3
- Fixed in
- 2.0.1, 1.10.4
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-cc8f-xg8v-72m3 lists affected ranges: npm compressing >=2.0.0 =0 <1.10.4 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-cc8f-xg8v-72m3 lists affected ranges: npm compressing >=2.0.0 =0 <=1.10.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.4 · CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2026-24884: 0.35% estimated exploitation activity in the next 30 days; percentile 28.41 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Arbitrary File Write via Symlink Extraction in github.com/node-modules/compressing Brief Introduction The compressing npm package extracts TAR archives while restoring symbolic links without validating their targets. By embedding symlinks that resolve outside the intended extraction directory, an attacker can cause subsequent file entries to be written to arbitrary locations on the host file system. Depending on the extractor’s handling of existing files, this behavior may allow overwriting sensitive files or creating new files in security-critical locations. Affected Component and Versions - Component: github.com/node-modules/compressing - Affected Versions: <= 1.10.3 || =2.0.0 Vulnerability Details Root Cause compressing.tar.uncompress sanitizes the destination paths of archive entries, but it does not restrict or validate the targets of symlinks contained in TAR archives. During extraction, the library creates those symlinks inside the output directory. Later entries that resolve…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-cc8f-xg8v-72m3
- Revision 1 · created ·
Published from osv record GHSA-cc8f-xg8v-72m3
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-24884 Advisory: Compressing Vulnerable to Arbitrary File Write via Symlink Extraction IDs: CVE-2026-24884, GHSA-cc8f-xg8v-72m3 Record: https://patchnext.com/advisories/cve-2026-24884 (revision 2, source checked 26 Oct 2026, 12:42 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: compressing 2.0.1, 1.10.4. A vendor fix does not mean a deployment is fixed. ## Affected components - npm compressing: affected >= 2.0.0, <= 2.0.0; <= 1.10.3; fixed in 2.0.1, 1.10.4 ## Suggested inspection (read-only) - `npm ls compressing --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on compressing. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-cc8f-xg8v-72m3 (OSV record GHSA-cc8f-xg8v-72m3 lists affected ranges: npm compressing >=2.0.0 =0 <1.10.4 (fixed)) - Verified: https://github.com/advisories/GHSA-cc8f-xg8v-72m3 (GitHub-reviewed advisory GHSA-cc8f-xg8v-72m3 lists affected ranges: npm compressing >=2.0.0 =0 <=1.10.3) Commands are suggestions: review each one before running it.
Loading voting…