Skip to content

← Actionable
Medium, CVSS 5.8

OpenFGA Improper Policy Enforcement

CVE-2026-24851GHSA-jq9f-gm9w-rwm9

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/openfga/openfga 1.11.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
5.8 · CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:N/VI:N/VA:N/SC:H/SI:H/SA:H · score source
EPSS
  • CVE-2026-24851: 0.34% estimated exploitation activity in the next 30 days; percentile 27.74 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact OpenFGA v1.8.5 to v1.11.2 ( openfga-0.2.22 <= Helm chart <= openfga-0.2.51, v.1.8.5 <= docker <= v.1.11.2) are vulnerable to improper policy enforcement when certain Check calls are executed. Affected Users Users are affected by this vulnerability if all of the following preconditions are met: - OpenFGA v1.8.5 to v1.11.2 is being used - The model has a relation directly assignable by a type bound public access and assignable by type bound non-public access - A tuple is assigned for the relation that is a type bound public access - A tuple is assigned for the same object with the same relation that is not type bound public access - A tuple is assigned for a different object that has an object ID lexicographically larger with the same user and relation which is not type bound public access Fix Upgrade to v1.11.3. This upgrade is backwards compatible. Workaround None

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-jq9f-gm9w-rwm9

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-24851

Advisory: OpenFGA Improper Policy Enforcement
IDs: CVE-2026-24851, GHSA-jq9f-gm9w-rwm9
Record: https://patchnext.com/advisories/cve-2026-24851 (revision 1, source checked 26 Oct 2026, 15:14 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/openfga/openfga 1.11.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/openfga/openfga: affected >= 1.8.5, <= 1.11.2; fixed in 1.11.3

## Suggested inspection (read-only)
- Go github.com/openfga/openfga: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/openfga/openfga.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-jq9f-gm9w-rwm9 (GitHub-reviewed advisory GHSA-jq9f-gm9w-rwm9 lists affected ranges: Go github.com/openfga/openfga >=1.8.5 <=1.11.2)

Commands are suggestions: review each one before running it.

Loading voting…